Using Open Workbench with Clarity

Self Paced Training Course
# Table of Contents

Module 1: Introduction ......................................................................................................................... 3
  1.1 Objectives ................................................................................................................................. 4
  1.2 Who Should Attend This Course .............................................................................................. 4
  1.3 SPT Course Preparation ............................................................................................................ 5
  1.4 SPT Course Method of Instruction ......................................................................................... 5

Module 2: Projects in Clarity ............................................................................................................. 6
  2.1 The Clarity / Open Workbench Integration .............................................................................. 7
  2.2 Navigating Project Information in Clarity ............................................................................. 7
  2.3 Working with Project Templates in Clarity ............................................................................ 11
  2.4 Project Scheduling Options in Clarity ................................................................................... 13
  2.5 Launching Open Workbench from Clarity ............................................................................ 15

Module 3: Project Staffing with Roles ............................................................................................. 16
  3.1 Project Staffing Process in Clarity ......................................................................................... 17
  3.2 Staffing Project Roles in Clarity ............................................................................................ 19

Module 4: Using Open Workbench ................................................................................................ 21
  4.1 Opening Open Workbench ..................................................................................................... 22
  4.2 Navigating Open Workbench .................................................................................................. 25
  4.3 Working with Views ............................................................................................................... 26
  4.4 Working with View Highlights .............................................................................................. 34
  4.5 Setting Workbench Options ................................................................................................... 35
  Exercises ........................................................................................................................................ 40

Module 5: Work Breakdown Structure ............................................................................................ 42
  5.1 Project Properties in OWB ..................................................................................................... 43
  5.2 Modifying the Work Breakdown Structure Using Views ...................................................... 48
  5.3 Working with Task Properties ............................................................................................... 52
  Exercises ........................................................................................................................................ 59

Module 6: Task Dependencies ......................................................................................................... 61
  6.1 Dependency Concept ............................................................................................................. 62
  6.2 Dependency Types and Lag .................................................................................................... 63
  6.3 Creating Dependencies .......................................................................................................... 66
  Exercises ........................................................................................................................................ 75

Module 7: Assigning Resources to Tasks ....................................................................................... 77
  7.1 Assigning Resources Using Views ....................................................................................... 78
  7.2 Assigning Resources Using Task Properties ....................................................................... 79
  7.3 Releasing a Resources from a Tasks ..................................................................................... 80
  Exercises ........................................................................................................................................ 82

Module 8: Project Scheduling .......................................................................................................... 84
  8.1 Factors Affecting Autoschedule ............................................................................................ 85
  8.2 The Critical Path .................................................................................................................... 85
  8.3 Using Autoschedule .............................................................................................................. 86
  8.4 Using Fixed and Variable Task Durations .............................................................................. 90
Module 1: Introduction

Clarity's Open Workbench application provides a seamless integration of a powerful project scheduler program with the powerful PPM application. With OWB, project managers can develop and maintain detailed project plans that include labor ETC and other resources and provides a foundational data basis to be leveraged by all other Clarity modules such as Resource Management and Financial Management.

This course was created by xPPM education, LLC and owns all rights to the material. The Project Management experience at xPPM-education is well over 30 years and the Clarity experience is well over 11 years, tracing the application back through Niku and through ABT, where much of it was originally created.

**Learning Objectives:**

Lesson 1: Course Purpose and Objectives

Lesson 2: Who Should Attend This Course

Lesson 3: SPT Course Preparation

Lesson 4: SPT Course Method of Instruction

Exercises – There are NO Hands-on practices in this Module
1.1 Objectives

This is an introductory course on the methods and use Open Workbench scheduling application interfaced with the Clarity PPM application. This course is the second course in a two-course series that in combination are BREAKTHROUGH training to kick-start your proper use of Clarity. This second course, together with the first course on Using Project and Resource Management with Clarity, will provide a base competency in Clarity Scheduling with Open Workbench and support transformational change in Project Management and Resources Management.

These transformational objectives are:

- Introduce Best Practice level Project Management and Resource Management using the Clarity application
- Provide the knowledge and guidance to Assignment level task planning using ETCs
- Build Best Practice project data that can be easily leveraged into powerful information throughout the Clarity application
- Build high quality resource Demand information to factually communicate the project resource demands with the Resource Manager.

1.2 Who Should Attend This Course

This class is principally aimed that those involved in both Project Management that use the Clarity PPM application. The course assumes a basic knowledge of Clarity and already has a logon to the system as well as basic understanding of project management concepts.
1.3 SPT Course Preparation

Prior to starting the actual SPT Course, you should have a printed copy of this course manual, have access to the Open Workbench application (which can be run in standalone mode on your PC), and have received the instructions for accessing and playing the SPT.

1.4 SPT Course Method of Instruction

This course is presented in the on-demand Self Paced Training (SPT) format and is intended to emulate the actual Instructor Led Training. The course instructor is Noland Eidsmoe, PE, PMP who has many years of project management and Clarity experience, which is highlighted in the course SPT.

Just like the Instructor Lead Training class, this course material is presented in lectures utilizing slides along with demonstrations from within the Clarity application as well as end of module exercises.

Because it is an SPT, you can take it at your convenience without the bother of going to a classroom, without having to take time away from the project, and can be taken as many times as you wish.
Module 2: Projects in Clarity

This module covers the common features in Clarity that affect the use experience in the various Clarity modules: Project Management, Resource Management, Portfolio Management, etc. In this lesson you will learn about the common features of Clarity and how to navigate and configure Clarity to effectively use the tool.

If you are already familiar with these features, you can use this as a refresher /review or just move on to the next module.

Learning Objectives:

Lesson 1: The Clarity / Open Workbench Integration

Lesson 2: Navigating Project Information in Clarity

Lesson 3: Working with Project Templates in Clarity

Lesson 4: Launching Open Workbench from Clarity

Lesson 5: Scheduling Options in Clarity

Exercises – There are NO exercises in this Module
2.1 The Clarity / Open Workbench Integration

Clarity and Open Workbench provide a fully integrated capability for the management of projects. Both applications share a common data model that allows data to be transferred between the two applications effectively. Several of the key touch points in the interface are described below:

- **Overview page**: the initial entry point into Clarity and use of My Projects Portlet
- **Projects List page**: one entry point to all projects
- **Project page**: the main landing point in entering the project in Clarity
- **Project Properties tab**: key project description and status information
- **Project Team tab**: the point of staffing the project with resources
- **Project Tasks tab**: scheduling internal to Clarity
- **Timesheet**: tracing time effort against project tasks

2.2 Navigating Project Information in Clarity

There are several key Clarity pages and portlets to assist the project manager in managing a project plan. This course addresses those related directly to using Open Workbench, including:

**Overview Page**

The Overview Page is the typical entry page when logging into Clarity. It can be configured by project managers to display information of interest to them. For example, the My Project is often a very useful portlet to be added to the page by project managers.
Projects list Page

Projects must be created in Clarity before you can access them in the Projects list. To access the Projects List page, click on the Projects link on the left Menu Bar. Use the filter at the top of the screen to quickly locate your project or use the Project List Screen navigation links to navigate to the page where your project is located.
(Project) Properties

Use a project’s properties pages to define project basics, from its name and schedule to baselines that capture snapshots of the project at various stages in its lifecycle. In addition, you can create projects from scratch or from a template.
(Project) Team
Use this component to build a team that includes the staff who will perform the tasks and non-staff participants who can assist staff by communicating information, suggestions, and concerns.

(Project) Tasks
Use the Tasks tab component to create tasks and to define a task hierarchy (WBS). You can also associate risks and issues to tasks to help monitor trouble spots.
Timesheets

It is common for most resources to report time using Clarity Timesheets. The task resource assignments are integrated into the team members timesheet to easily report time against the tasks to which they have been assigned. To view your timesheet, click on Timesheets in the left Menu Bar. There will be more on timesheets in the Monitoring and Control module.

2.3 Working with Project Templates in Clarity

As the Project Manager on a created project, you have the ability to add template information into the existing project. From the Properties tab and the Main sub link, notice that there is a link Copy from Template on the upper right side of the project information, just below the blue area.
Clicking on the Copy from Templates link will present the Select Project Template page to select from the list of templates that have been configured in Clarity.

The template can have a complete Work Breakdown Structure (WBS) of Phases, Activities, Tasks, and Milestone and have dependencies defines as well as Role assignments and the Role ETC for each Task.

After selecting the Template to add into your project, you then have the option to Scale the work defined in the Template by a percentage or you can leave it at 0% and the Template amounts will be applied to your plan.
2.4 Project Scheduling Options in Clarity

With Clarity there are three methods of developing project schedules:

1. Using the Clarity Application
2. Using Open Workbench
3. Using Microsoft Project

1. Using the Clarity Application (Tasks)

Follow the TASKS tab to work the schedule in the browser. While it is tempting to think of doing all the project scheduling in a web browser, the instructor recommends that this be used only in the early stages of use maturity where there is only one Bucket Task per Project or there is only one Bucket Task per Phase. For either of these alternatives, there would be little or no build of task information in Clarity. For one Bucket Task per Phase case, this should be accomplished with the Create from Template approach and is the only case that will be used in this course for working in the Clarity Application.
2. Using Open Workbench

Open Workbench is a scheduling application that is seamlessly interfaced with Clarity. It is launched simply by clicking the GO button on the Menu line that reads “Open in open Workbench”

Here is the same phase – level task bucket schedule displayed in Open workbench (OWB). This was launched by clicking on the GO from the Project Properties tab. And in fact, you can create this schedule in OWB as below and then view it in Clarity TASKS tab as above. Or just the opposite – create in Clarity and view in OWB – its all the same data.
3. Using Microsoft Project

Using MSP acts the same was as OWB. However, the Project must be set up by the Clarity Administrator to interface with MSP. In that case, the GO button on the Menu line reads “Open in Microsoft Project”

Several words of caution:

- NEVER use both MSP and OWB on a schedule, much be one or the other
- There are RULES for use of MSP in Clarity that are much different than the way MSP is used as a desktop scheduler and must be followed (e.g. summary level task dependencies are NOT allowed).

2.5 Launching Open Workbench from Clarity

To launch OWB from Clarity you must be in the Project Properties and then click on the Go button next to Open in Open Workbench. The is will open OWB with the project information from which it was launched into the default view defined in OWB. If you are the Project Manager, you will be able to open OWB in Read/Write mode, but if you do not have edit rights to the project, you will only be able to open the project in Read mode.
Module 3: Project Staffing with Roles

It is important that the project plan be developed right from the beginning by the Project Manager with the idea that the resources will actually be staffed by the Resource Manager and that in order for that to occur, the Project Manager must have fact-based data as a basis of the request to the Resource Manager. That is done by first planning the project using Roles.

Learning Objectives:

Lesson 1: Project Staffing Process in Clarity
Lesson 2: Staffing Project Roles in Clarity
Exercises – There are NO exercises in this Module
3.1 Project Staffing Process in Clarity

The project staffing/fulfillment process is key to Best Practice resource management and keeping resource allocations within the resource availability. The process was covered in great detail in the Using Project and Resource Management with Clarity course and is only summarized below:

1. The project is typically created by a Project Creator who populates the following:
   - Key data fields populated.
   - Linked to OBS reporting structures.
   - WBS Template added or left for the Project Manager to add the Template.
   - Project Manager assigned and given project Rights.
2. **Project Manager builds the project plan:**
   - In [Clarity] Adds Roles and sets initial allocations.
   - In [OWB] Updates the Work Breakdown Structure.
   - In [OWB] Assigns Roles to tasks and ETC hours.
   - In [OWB] Creates Dependency Links between Tasks and Milestones.
   - In [OWB] Schedules the plan.
   - In [Clarity or Clarity] Baselines the plan.

3. **Project Manager requests Resources to replace Roles:**
   - In [Clarity Team tab] select all team staff members and click the More button then select Allocate from Estimate.
   - The Role project demands are now set to the project plan
   - Project Manager then communicates with Resource Manager – in person, phone, or email
   - Will also rely on the Resource Management portlet in Resource Planning

4. **Resource Manager fulfills the Resource requests:**
   - Using Resource Finder, the Resource Manager locates a resource
   - Considerations: Role, Availability, and skills

5. **Project Manager replaces Roles with Resources allocated by the Resource Manager:**
   - This may be the RM in some organizations

6. **Resource Manager commits the allocated Resources:**
   - Changes the booking to ‘Hard Booked’
3.2 Staffing Project Roles in Clarity

Item 2 in the above Project Staffing / Fulfillment process chart is **Project Manager builds the project plan** and the first step in that is: **In [Clarity] Adds Roles and sets initial allocations.** This step is performed in the Team tab in Clarity and the Staff sub-link. This is where the Roles are first added to the project by selecting the Add button at the bottom of the screen.

The list of Roles and Resources is listed, which should be Filtered for Is Role = Yes.
By filtering for Is Role = Yes, only Roles are listed. From there, select the Roles that will be needed to perform the project.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Project Role</th>
<th>Time</th>
<th>Booking Status</th>
<th>Request Status</th>
<th>Start</th>
<th>Finish</th>
<th>% Allocation</th>
<th>Allocation</th>
<th>Actuals</th>
<th>ETC</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSK Architect</td>
<td>GSK Architect</td>
<td>Soft Now</td>
<td>9/21/09-11/13/09</td>
<td>100.0%</td>
<td>320.00</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GSK Business Analyst</td>
<td>GSK Business Analyst</td>
<td>Soft Now</td>
<td>9/21/09-11/13/09</td>
<td>100.0%</td>
<td>320.00</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GSK Project Manager</td>
<td>GSK Project Manager</td>
<td>Soft Now</td>
<td>9/21/09-11/13/09</td>
<td>100.0%</td>
<td>320.00</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Total: 960.00 0.00 0.00
Module 4: Using Open Workbench

Open Workbench is seamlessly integrated with Clarity and allows the formation of a powerful and detailed project plan that can then be used to monitor and control the project through its life cycle.

Learning Objectives:

Lesson 1: Opening Open Workbench
Lesson 2: Navigating Open Workbench
Lesson 3: Working with Views
Lesson 4: Working with View Highlights
Lesson 5: Setting Workbench Options

Exercises – Hands-on practices
4.1 Opening Open Workbench

You can open Open Workbench from Clarity or direct from your computer’s Start menu.

Follow these steps to open Workbench from Clarity

*(NOTE: this is the normal approach):*

1. Log in to Clarity.
2. Open a project from the Projects page.
3. In the Main section of the Properties tab, from the Open in Workbench dropdown list, select either value, Read/Write or Read Only.
4. Select Go.
Workbench launches and the schedule opens in the default view.

Follow these steps to open OWB from the Start Menu

(NOTE: this is the method used in this course to perform the Exercises)

1. From Start>All Programs, select Open Workbench.

2. If you are not logged in to Clarity, enter your ID and password.

Note: If you wish to use Open Workbench disconnect to Clarity, just click on the Cancel button at the Log On box and do not enter a Password. You can now use OWB as a Desktop Only scheduler using the Open Workbench files of *.rmp format.

3. To open a project plan, select the File menu, then Open.

4. The Open dialog box appears. Open a specific project plan by double-clicking on the external ID listed in the ID column.
NOTE: It is recommended you open projects from Clarity, rather than Workbench, because Clarity has a robust filter for finding and selecting a project. The SPT Course will use this Method only because we are working with OWB project files.

NOTE: The Padlock on the project ID in the OWB Open box shows that the project is Locked as it was ‘checked-out’ to Open Workbench from Clarity. In Clarity, the project also shows as Locked in pages that are locked. Note that the Lock can be managed by the “locked by” user by pressing the Unlock button. This should only be done after the OWB changes have been saved back to Clarity.

5. [Optional] To save the project plan to your local hard drive, select Save As, then locate where you want the file saved.
**NOTE:** Make sure to select the **Retain Lock** checkbox. You have checked your project out of Clarity, and this lock allows you to return the project to Clarity, while preventing other users (with rights to your project) from making changes while the lock is on. If you do not Retain the Lock, you will NOT be able to save the project changes back to Clarity (yes, this does happen!).

**NOTE:** Do not use **Save As** again until you are ready to put the project back in Clarity. A second **Save As** removes the lock.

### 4.2 Navigating Open Workbench

Workbench views are displayed in windows. The following screenshot shows the various sections of the Workbench interface.

To view task properties, double-click the row selector for the task or right-click the task and select **Modify**.
4.3 Working with Views

Workbench data is displayed in views. These views are in groups visible in the View Shortcut bar on the left side. The standard view groups are organized in a natural progression suited for building a project schedule.

Views can be modified and saved as new views to aid in project analysis.

Views can also be configured and printed to assist in reporting.
NOTE: To display additional views without closing the current view, right-click on the desired view and select New Window from the menu. A tab for the new view appears at the bottom of the Workbench session.

Using Views

Views are comprised of data elements or attributes. To edit or review view layouts, access the View Definition window using the F3 key or selecting Edit View from the View menu. Data attributes are configured in the Layout section of the View Definition window.
Adding a Column

To add a column to the View Definition: Layout tab:

1. Highlight the column by clicking in its top, gray area.

2. Right-click or press the Insert key to insert a new blank column to the left of the highlighted column.

Adding a Data (attribute)Field

To add a data field:

1. Select the desired data field from the appropriate folder on the left side of the View Definition window. There is an All folder for both resource and task fields that is helpful in finding a data field. It places all the fields under the primary folder in alphabetical order.

2. Add the Name field to the view by selecting it, then dragging and releasing it in the appropriate cell of the selected column.
3. Select OK to close the View Definition window and reopen the view.

Deleting a Column
To delete a column from the View Definition window:

1. Highlight the column you want to delete.

2. Right-click or press the Delete key to delete the column.

Formatting a View
Formatting properties can be set for each field in a view.

1. Select the Layout tab of the View Definition window.

2. Select a cell and click the Format Cell button. You can also double-click on the cell or right-click on the cell and select Format from the menu.
3. The Formatting Options dialog box displays a number of options. These options vary depending on the data field selected (some may be grayed out).

4. Select OK to save the changes.

In the Description tab of the View Definition window, you access the following fields, along with additional descriptive information:

- **View Type** field
- **Level of Analysis** field
- **Name** field
- **Resource LOA (Level of Analysis) checkbox**

**NOTE:** The Resource LOA checkbox should be selected for filtering on individual resource data (for example, ETC, actuals, and tasks).
Sorting criteria is defined in the **Sort** section of the **View Definition** window.

![Sort section of View Definition window](image1)

Use the **Filter** tab of the **View Definition** window to define filter criteria.

![Filter section of View Definition window](image2)

**NOTE:** Utilize wildcards for filtering, such as * (* = all) and ? ( ? = placeholder).

**Changing the View Time Scale**

The time scale of a view (tabulated field) can be changed by:

1. Double-clicking in the **Time Scale** pane opens the **Time Scale** dialog box.

![Time Scale pane](image3)
2. Change the Time Scale parameters, as required.

3. Select OK to reset and exit the Time Scale dialog box.

Saving a Modified or Edited View as a New View

To save a modified or edited view as a new view, you must ensure it has a unique name so that it does not appear as a duplicate in the View Shortcut bar. This name is defined on the Description tab of the View Definition window.

The Name entered in the Name field is the view name that displays in the View Shortcut menu on the left.
1. Select View > Save View. You will be asked to give the view a file name.  

   **NOTE:** For best results, give the view a file name that matches the view name.

2. Select a library group.

3. Select Save when finished. The new view, Rick’s Gantt Chart, appears in the view library and the View Shortcut bar.
Using Open Workbench with Clarity

Using the View Library

Adding Views to View Folders
Follow these steps to add a new view:

1. A view file will be sent to you as an e-mail attachment. Store the .rwv file in the C:\Open Workbench\Views directory.

2. Open the Libraries dialog box, from the View menu.

3. Select the folder in which you want to store the view.

4. Select Add.

5. Locate the file in the directory.

6. Select Open and the view is added to the folder.

7. Select Close to complete the addition process.

Removing Views
Remove a view from a folder by opening the Libraries dialog box, locating the view, and selecting Remove.

NOTE: You cannot remove corporate views. They are protected and cannot be removed or altered, except by the Clarity/Open Workbench system administrator.

4.4 Working with View Highlights

To determine the meaning of certain font and background colors, select View>Highlights from the menu bar.
Highlights can be created or edited based on individual needs, although it is recommended that you standardize highlight settings across your organization to ensure consistent data analysis.

### 4.5 Setting Workbench Options

In Workbench, you can set program defaults specific to your PC. From the Tools menu, select Options to open the Options window. Each of the tabs in the Options window is described in this section.

**Options: General Tab**
The **Options: General** tab contains the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Tips at Startup</td>
<td>Turns off/on the pop-up tips you see when first logging on.</td>
</tr>
<tr>
<td>Display Status Bar</td>
<td>Turns off/on the status bar at the bottom of page.</td>
</tr>
<tr>
<td>Log on to Clarity</td>
<td>Turns off/on the ability to log on to Clarity. If this is off, the pop-up login box will not appear when Workbench opens.</td>
</tr>
<tr>
<td>View Shortcut Bar</td>
<td>Turns off/on the shortcut bar on the left side of the window and which holds your views</td>
</tr>
<tr>
<td>Recent Project List File Contains</td>
<td>Dictates how many recent files are listed at the bottom of the file menu item.</td>
</tr>
<tr>
<td>Default Project Format</td>
<td>Choose whether your projects should default to repository projects (Clarity) or to standalone projects (.rmp).</td>
</tr>
<tr>
<td>First Week of Year</td>
<td>Choose the appropriate option to indicate the first week of the current year.</td>
</tr>
<tr>
<td>Default Currency</td>
<td>Choose the default currency for Workbench. If no setting is selected, Workbench inherits the default setting for Clarity.</td>
</tr>
<tr>
<td>Warn When Reading or Writing Different Currencies</td>
<td>System warns if different currencies are detected from your system currency.</td>
</tr>
<tr>
<td>Guidelines URL</td>
<td>The name of the guideline file being used, if any.</td>
</tr>
<tr>
<td>Note Categories</td>
<td>The names of the note categories to be available when notes are created. These values are available for Project, Task, and Resource notes.</td>
</tr>
</tbody>
</table>
The **Options: Defaults** tab contains the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assignment Loading Pattern</td>
<td>Choose a default loading pattern:</td>
</tr>
<tr>
<td></td>
<td>- Uniform</td>
</tr>
<tr>
<td></td>
<td>- Fixed</td>
</tr>
<tr>
<td></td>
<td>- Contour</td>
</tr>
<tr>
<td></td>
<td>- Front</td>
</tr>
<tr>
<td></td>
<td>- Back</td>
</tr>
<tr>
<td>Fixed Duration</td>
<td>Select this box if the tasks should default to a fixed duration. If unselected, task duration is calculated to be as short as possible, based on the properties of the task and its assignments. If Fixed Duration is checked as the Default, then the Default Assignment Loading Pattern above should be set to <strong>Contour</strong>.</td>
</tr>
<tr>
<td>Default Unit</td>
<td>Choose whether Workbench calculates based on hours or days for this project.</td>
</tr>
<tr>
<td>Dependency Type</td>
<td>Choose one of the four options as the default dependency type. This value can be changed each time a dependency is created.</td>
</tr>
<tr>
<td>Dependency Lag</td>
<td>Choose the default amount of lag to place between tasks when creating a dependency. This value can be changed each time a dependency is created.</td>
</tr>
<tr>
<td>Dependency Lag Type</td>
<td>If you set a lag, choose the appropriate lag type.</td>
</tr>
</tbody>
</table>
Percent Complete Values Based On:

Throughout the application, you can view a Percent Complete field. This value can be obtained via one of two methods. Each user can decide which method drives the Percent Complete field.

- User Entered Value – Anyone with access can type a percent complete number.
- % Expended – A calculated value based on the total estimate of the task and the number of actual hours that have been recorded.

Options: Location Tab

The Options: Location tab displays the following paths:

<table>
<thead>
<tr>
<th>Path</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate View Library</td>
<td>The path to the shared views created by an organization as its own organizational views (if used).</td>
</tr>
<tr>
<td>User View Library</td>
<td>The path to the views you have created personally and want to be visible in your library.</td>
</tr>
<tr>
<td>Highlights File</td>
<td>The path to the highlight file you would like to use. It can be the standard file or a custom file.</td>
</tr>
<tr>
<td>Default View</td>
<td>The path to the view you would like shown by default each time the application opens.</td>
</tr>
<tr>
<td>Projects File</td>
<td>The path to the project files.</td>
</tr>
<tr>
<td>Global File</td>
<td>Not used.</td>
</tr>
</tbody>
</table>
Options: WBS Tab

The **Options: WBS** tab is where you can set WBS levels.

**NOTE:** Resource ETC assignments and actuals are always tracked at the lowest WBS level.

Options: Display Tab

Select the **Display** tab to change the display of your spreadsheet views. You can change the color of lines and the background. These changes affect only your computer.
Exercises

Exercise 1 - View Navigation

**NOTE**: SPT Class Exercises are being done in OWB Standalone mode, not connected with Clarity. This will allow you to do the exercises from anywhere without being connected to a Clarity server. The easiest way to work with OWB Files is to Open the File using Windows Explorer and double click the OWB File (OWB Files are *.RMP type).

1.1 On your computer, open Open Workbench

1.2 Open the SPT Course provided project file: **OWB Student File 1 - Navigation.rmp** (File>Open and browse to the location that you have stored the class file)

**Note**: This project file is a completed project file that is being used now so that we can more fully review the OWB Views.

1.3 From the Favorites Group, select the Gantt Chart view and Open the View Definition window (F3) and select the Layout Tab.

1.4 Add a new column before the Gantt data element (right click the column and select **insert**).

1.5 Add the **Duration** data element to the view. From the Data Element list on the left side of the View Definition, use **Task Information>Dates & Duration**, find and add the **Duration** data element to the new column (drag the data element to the new cell (in the Task Detail Section of the view) which should be to the immediate left of the work Gantt).

1.6 Format the **Task Start**, **Task Finish** and **Duration** data elements to show **Column Totals** (select each data element and then click the **Format Cell** button (or double click the data element) and check Column Totals.

1.7 Go to the **Description tab** and rename the view **My Gantt Chart**. Select **OK**.

1.8 From the Menu, select **View>Save View**. Select **Create** in the View Definition Save Query box and save the view to the **Open Workbench/View/EN** folder. Give the view the File Name given in the previous step (**My Gantt Chart**). Leave it in the **Favorites** Library Group selection and select **Save**.

1.9 Select the new **My Gantt Chart** View. Change the Time Scale to a Scale of **Weekly** and **15** Number of Periods. Select **OK**. Select **View>Save View**. Then Select **Replace** in the View Definition Save Query box (no save is required).
**Exercise 2 - View Navigation**

View the project in the Planning Group, **WBS Definition** view. Notice the Type Field displays the Task Type data element for each task – **Phase**, **Task**, or **Milestone**. View this data element by pressing F3, then click Cancel to leave the view and the exercise.
Module 5: Work Breakdown Structure

The Work Breakdown Structure (WBS) is the term that refers to the project’s task and milestone that are organized into phases and then include summary tasks above the phases. Clarity makes the development of the WBS much easier by the use of project templates, which can include a complete project WBS, staffing, and task assignments with efforts.

Learning Objectives:

Lesson 1: Project Properties in Open Workbench

Lesson 2: Modifying the Work Breakdown Structure Using Views

Lesson 3: Working with Task Properties

Exercises: Hands-on practices
5.1 Project Properties in OWB

Project properties are defined and managed primarily through the Clarity UI, and, with the exception of the scheduling settings, there should be no need to edit the properties data.

To access the Project Properties window, select File>Properties. Each of the tabs in the Project Properties window is described in this section.

Project Properties: Description Tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the project. This is visible in the web interface as the project name. This information comes from Clarity.</td>
</tr>
<tr>
<td>ID</td>
<td>The project ID. This is visible in the web interface as the project ID. This information comes from Clarity.</td>
</tr>
<tr>
<td>Department</td>
<td>The department for the project. This is not linked to the financial properties of the project. This value is not visible in the web interface.</td>
</tr>
<tr>
<td>Budget</td>
<td>The total budget for the project. This is not linked to the financial properties of the project. This value is not visible in the web interface.</td>
</tr>
<tr>
<td>Description</td>
<td>The description of the project. This is visible in the web interface as the project description. This information comes from Clarity.</td>
</tr>
</tbody>
</table>
**CAUTION:** Do not change the project ID under any circumstance. This would prohibit you from saving the project back to the Clarity database.

**Project Properties: Scheduling Tab**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Date</td>
<td>The current start date of the project. This is visible in the web interface as the start date.</td>
</tr>
<tr>
<td>Finish Date</td>
<td>The current finish date of the project. This is visible in the web interface as the finish date.</td>
</tr>
<tr>
<td>Imposed</td>
<td>Check this box to freeze the start or finish date. When checked, autoschedule cannot move the start or finish date. This is <em>not</em> visible in the web interface.</td>
</tr>
<tr>
<td>As-of</td>
<td>The date the project was last saved. This is visible in the web interface as the As-of Date.</td>
</tr>
<tr>
<td>Priority</td>
<td>The path to the project files.</td>
</tr>
<tr>
<td>Critical Path Type</td>
<td>Determines the type of Critical Path displayed for the project. Either current or baseline. This is <em>not</em> visible in the web interface.</td>
</tr>
<tr>
<td>Subnets</td>
<td>Allows for subnets to be created in projects. <em>Subnets</em> are a group of tasks within a project that have dependencies among themselves and their own Critical Path can be created. This is <em>not</em> visible in the web interface.</td>
</tr>
</tbody>
</table>

**NOTE:** If neither date is imposed, the start and finish date fields display the earliest start date and the latest end date for the project, respectively.
Using Open Workbench with Clarity

Project Properties: Resources Tab

The Resource tab displays resources assigned to the project team.

<table>
<thead>
<tr>
<th>Fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Team Resources</td>
<td>This table displays the resources assigned to this project.</td>
</tr>
<tr>
<td>Global Resources</td>
<td>This box allows you to view and add roles and resources from the global resources in Clarity.</td>
</tr>
</tbody>
</table>

**NOTE:** Resources should only be staffed to the project in Clarity

Project Properties: Key Tasks Tab

Workbench displays summary level information for all tasks marked as key tasks in the Key Task tab. Key Task is a “flag” field that can be checked or unchecked. That does not change the task in anyway—it allows you to sort or filter key tasks for reporting purposes.

One of the field’s best uses is to identify critical milestones as key tasks so that management can focus quickly on the status of a project by looking at a limited number of milestones.

Consider the following factors when identifying a task as a key task:

- Not all milestones should be key tasks
- Key tasks do not represent the “importance” of a task; they represent an important “measurement” point in a project plan.
- There should be enterprise–wide standards for assigning key-task status, which should be determined by individual project managers.
The key task function does not have to be used at all.

<table>
<thead>
<tr>
<th>Display</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key Task Display</td>
<td>This page displays any tasks marked as “key”. These tasks are also visible in the web interface on the Tasks tab.</td>
</tr>
</tbody>
</table>

**Project Properties: Advanced Tab**

You can review all project attributes in the Advanced tab. Although attributes may be scattered among four or five different portlets in Clarity, the Advanced tab presents them in neat, alphabetical order.

You can edit the values of these attributes both in the Clarity UI and in Workbench properties windows.
Using Open Workbench with Clarity

## Advanced Fields
These fields are both data entry and calculated fields that are discussed individually throughout this manual. This tab displays the current values for these fields. Some are available in the web interface, some are not.

### Project Properties: Notes Tab
Add project notes using the **Notes** tab.
### Using Open Workbench with Clarity

<table>
<thead>
<tr>
<th>Fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notes View</td>
<td>Notes can be typed, associated with a category, saved, and reviewed from this tab. Only notes associated with the project will be visible here. These notes can be viewed from the Notes link on the Project Overview page in the web interface.</td>
</tr>
</tbody>
</table>

The following conditions apply to the note functionality:

- There is no automated notification that a note has been written.
- You must create a custom view to see the note in a spreadsheet view.
- Only the most recent note can be displayed in a view.

#### 5.2 Modifying the Work Breakdown Structure Using Views

Frequently the existing Work Breakdown Structure (WBS) needs to be edited to meet the adjusting requirements of the project. This is especially the case when the project is created from a Template or a Template is added in. WBS line items can be inserted, deleted, and moved.

**Inserting Lines**

**Inserting a Line Using the Menu**

1. Highlight the row below where you would like the new row to appear.
2. Right-click the mouse and select **Insert Task**.
3. A new line displays above the one you selected.
Inserting a Line Using the Insert Button

1. Highlight the row below where you would like the new row to appear.
2. Press the Insert key on your keyboard.
3. A new line displays above the one you selected.

Deleting Line Items

Lines may need to be removed in your plan. Use one of the following methods to delete line items.

Deleting a Line Using the Menu

1. Highlight the row you would like to delete.
2. Right-click the mouse and select Delete Task.
3. The line is removed.
Deleting a Line Using the Delete Button

1. Highlight the row you would like to delete.

2. Press the **Delete** key on your keyboard.

3. The line is removed.

**NOTE:** Tasks cannot be deleted if they have resource actuals posted against them.

Moving Line Items

When working with projects, you can cut, copy, and paste data from the task and resource sections of any view, as well as from the Gantt chart. You can also select a task(s) and drag and drop it to a new location. When you copy task data, you can select specific task fields (cells) in a view or the entire task (using the row selector). Selecting the entire task copies all task data, including resource assignments and dependencies. When using **Paste Special**, you can decide which task data is pasted, allowing the user to **not include** resource assignments and or dependencies, if preferred.

Cutting and Pasting Data

1. Select the cell or rows to cut in the spreadsheet view.

2. Select **Edit>Cut**. Right-click the mouse and select **Cut** or **Ctrl+X** to cut data.

3. Highlight the row below where the new information will be pasted.

4. Select **Edit>Paste**. Right-click the mouse and select **Paste** or **Ctrl+V** to paste data.
Copying and Pasting Data

1. Select the cell or rows to copy in the spreadsheet view.

2. Select Edit>Copy. Right-click the mouse and select Copy or Ctrl+C to copy data.

3. Highlight the row below where the new information will be pasted.

4. Select Edit>Paste. Right-click the mouse and select Paste or Ctrl+V to paste data.

**NOTE:** If you want to preserve the WBS hierarchy of items when copying cells of data, it is essential to include the Type field. If the Type field is missing, Workbench pastes all items as tasks (the default WBS level).

Using the Paste Special Command

1. Select the cell or rows to copy in the spreadsheet view.

2. Select Edit, Copy, the appropriate icon on the toolbar, or Ctrl+C to copy the data.

3. Highlight the row below where the new information is to be copied.

Choose the appropriate options for your pasted tasks.

Select OK.

### 5.3 Working with Task Properties

Task information can also be modified using several methods, one of which is the Task Properties.

#### Modifying Task Properties

Modify task properties using any of the following methods:

- Double-click the row selector of a particular task (the box area on the task left side).
- Right-click and select Modify.
- Place your cursor in the task line, select Edit>Modify from the menu bar.
- Press F8.

Any of these actions opens the Task Properties window.
Task Properties: General Tab

![Task Properties: General Tab](image)

The **Task Properties: General** tab contains the following fields:

<table>
<thead>
<tr>
<th><strong>Field</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the task. (User-defined.)</td>
</tr>
<tr>
<td>Category</td>
<td>Allows for a user-defined grouping of tasks. No dropdown list available.</td>
</tr>
<tr>
<td>ID</td>
<td>The ID of the task. (User-defined.)</td>
</tr>
<tr>
<td>Type</td>
<td>Determines the roll-up of the WBS. Values include:</td>
</tr>
<tr>
<td></td>
<td>- Task</td>
</tr>
<tr>
<td></td>
<td>- Milestone</td>
</tr>
<tr>
<td></td>
<td>- Activity</td>
</tr>
<tr>
<td></td>
<td>- Phase</td>
</tr>
<tr>
<td>Key Task</td>
<td>Checkmark indicates a key task.</td>
</tr>
<tr>
<td>Duration</td>
<td>The number of days the task will take to complete. Default is an acceptable value. For a variable duration, the value is calculated during autoscheduling. For a fixed duration, the value is entered by the user.</td>
</tr>
<tr>
<td>Fixed</td>
<td>If checked, the duration of the task will be locked to the number of days set in the <strong>Duration</strong> field and will not change during scheduling.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Priority</td>
<td>A priority for your task between 0 and 36 (0 is highly important and 36 is of lowest priority). This is used if two tasks require the same resources at the same time. The lower priority is given preference during autoscheduling. The default is 10.</td>
</tr>
<tr>
<td>Inherited</td>
<td>If checked, the priority is inherited from the project, if this box.</td>
</tr>
<tr>
<td>Current Start/Finish</td>
<td>The current start and finish dates of the task.</td>
</tr>
<tr>
<td>Baseline Start/Finish</td>
<td>The start and finish of the task the last time it was baselined.</td>
</tr>
<tr>
<td>Early Start/Finish</td>
<td>The earliest a task can start and finish without affecting the Critical Path. Calculated by the system when the Critical Path is calculated.</td>
</tr>
<tr>
<td>Late Start/Finish</td>
<td>The latest a task can start and finish without affecting the Critical Path. Calculated by the system when the Critical Path is calculated.</td>
</tr>
<tr>
<td>Status</td>
<td>The current status of the task:</td>
</tr>
<tr>
<td></td>
<td>- Not Started</td>
</tr>
<tr>
<td></td>
<td>- Started</td>
</tr>
<tr>
<td></td>
<td>- Completed</td>
</tr>
<tr>
<td><strong>Status</strong></td>
<td>Updates automatically to Started when actuals are posted against the project. The field can also be updated manually before the first actuals have posted. The update to Completed must be done manually. A change in the status to Completed automatically changes the <strong>% Complete</strong> field to 100.</td>
</tr>
<tr>
<td>% Complete</td>
<td>The percent of work performed on a task to date. This is either populated by a user-entered value or is calculated by the system, depending on the system options defaults.</td>
</tr>
</tbody>
</table>
Task Properties: Resources Tab

The Task Properties: Resources tab contains the following displays:

<table>
<thead>
<tr>
<th>Display</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assigned Resources</td>
<td>Assigned Resources displays the resources already assigned to this task and their estimated time to complete.</td>
</tr>
<tr>
<td>Project Resources</td>
<td>Project Resources displays any resources already added as staff to the project. This is visible in the web interface on the Team tab.</td>
</tr>
</tbody>
</table>
Task Properties: Dependencies Tab

The Task Properties: Dependencies tab contains the following displays:

<table>
<thead>
<tr>
<th>Display</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dependencies</td>
<td>All dependencies for this task.</td>
</tr>
<tr>
<td>Project Tasks</td>
<td>All tasks available for creating dependencies.</td>
</tr>
</tbody>
</table>
Task Properties: Advanced Tab

The Task Properties: Advanced tab contains the following displays:

<table>
<thead>
<tr>
<th>Display</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints Fields</td>
<td>The fields in both displays are both data entry and calculated/protected fields discussed throughout this manual. These displays show current values for this task. Some constraint fields are available in the Clarity UI.</td>
</tr>
</tbody>
</table>
Task Properties: Notes Tab

From this tab, you can type notes, associate them with a category, save them, and review them. Only notes associated with a task are visible in this tab. You can also view them from the Notes link on the Task Properties page in the web interface (which can also be accessed from the timesheet).
Exercises

Exercise 5 – Creating the Work Breakdown Structure

1. Modify the WBS Definition view.
   a. Open the SPT Course provided project file: OWB Student file 2 - Student Exercise.rmp (the Project Name of this file is OWB Student Exercise Project). The Project Team comprised of Roles has already been added (you would normally do this in Clarity).
   b. Open the Planning group on the View Shortcut bar and select the WBS Definition view.
   c. Enter view definition mode by pressing the F3 shortcut key.
   d. Highlight the Category column and delete it.
   e. Open the Task Information folder followed by the Dates and Durations folder. Select the Fixed Duration? data element and drag and drop it over the Deliverable data element in the view layout.
   f. Go to the View>Save View menu and select Replace.

2. Create the WBS in the WBS Definition view: Create the WBS laid out in the following table below, using the WBS Definition view (in the Planning folder).

3. Save your changes to the file: OWB Student file 2 - Student Exercise.rmp when you have completed building the WBS.

   **NOTE:** You will be using this File /Project for the next series of exercises. Each exercise builds on the previous exercise. You must complete each exercise and save your project plan. Follow the instructor demo to ensure your project plan is correct before you go on to the next module.

<table>
<thead>
<tr>
<th>Type</th>
<th>ID</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Milestone</td>
<td>.99</td>
<td>Project Start</td>
</tr>
<tr>
<td>Type</td>
<td>ID</td>
<td>Name</td>
</tr>
<tr>
<td>--------</td>
<td>-----</td>
<td>------------------------------------------------</td>
</tr>
<tr>
<td>Phase</td>
<td>1</td>
<td>Initiate</td>
</tr>
<tr>
<td>Task</td>
<td>1.05</td>
<td>Review the Business Justification</td>
</tr>
<tr>
<td>Task</td>
<td>1.10</td>
<td>Define High Level Business Requirements.</td>
</tr>
<tr>
<td>Milestone</td>
<td>1.99</td>
<td>Initiate Phase Complete</td>
</tr>
<tr>
<td>Phase</td>
<td>2</td>
<td>Define</td>
</tr>
<tr>
<td>Task</td>
<td>2.05</td>
<td>Create Requirements Matrix</td>
</tr>
<tr>
<td>Task</td>
<td>2.10</td>
<td>Define Function 1</td>
</tr>
<tr>
<td>Task</td>
<td>2.15</td>
<td>Define Function 2</td>
</tr>
<tr>
<td>Task</td>
<td>2.20</td>
<td>Define Function 3</td>
</tr>
<tr>
<td>Milestone</td>
<td>2.99</td>
<td>Define Complete</td>
</tr>
<tr>
<td>Phase</td>
<td>3</td>
<td>Design</td>
</tr>
<tr>
<td>Task</td>
<td>3.05</td>
<td>Review Function Documentation</td>
</tr>
<tr>
<td>Task</td>
<td>3.10</td>
<td>Design Function 1</td>
</tr>
<tr>
<td>Task</td>
<td>3.15</td>
<td>Design Function 2</td>
</tr>
<tr>
<td>Task</td>
<td>3.20</td>
<td>Design Function 3</td>
</tr>
<tr>
<td>Milestone</td>
<td>3.99</td>
<td>Design Complete</td>
</tr>
<tr>
<td>Phase</td>
<td>4</td>
<td>Develop</td>
</tr>
<tr>
<td>Task</td>
<td>4.05</td>
<td>Review Design Documents</td>
</tr>
<tr>
<td>Task</td>
<td>4.10</td>
<td>Build Function 1</td>
</tr>
<tr>
<td>Task</td>
<td>4.15</td>
<td>Build Function 2</td>
</tr>
<tr>
<td>Task</td>
<td>4.20</td>
<td>Build Function 3</td>
</tr>
<tr>
<td>Milestone</td>
<td>4.99</td>
<td>Build Complete</td>
</tr>
<tr>
<td>Phase</td>
<td>5</td>
<td>Implement</td>
</tr>
<tr>
<td>Task</td>
<td>5.05</td>
<td>Conduct System Test</td>
</tr>
<tr>
<td>Task</td>
<td>5.10</td>
<td>Conduct User Test</td>
</tr>
<tr>
<td>Task</td>
<td>5.15</td>
<td>Set up Production Environment</td>
</tr>
<tr>
<td>Task</td>
<td>5.20</td>
<td>Go Live</td>
</tr>
<tr>
<td>Milestone</td>
<td>5.99</td>
<td>Implementation Complete</td>
</tr>
<tr>
<td>Phase</td>
<td>6</td>
<td>Project Management</td>
</tr>
<tr>
<td>Task</td>
<td>6.05</td>
<td>Project Control and Admin</td>
</tr>
<tr>
<td>Task</td>
<td>6.10</td>
<td>Meetings</td>
</tr>
<tr>
<td>Milestone</td>
<td>9.99</td>
<td>Project Complete</td>
</tr>
</tbody>
</table>
Module 6: Task Dependencies

After defining the project work, you need to consider the logical sequence of the tasks. Logical links between tasks and milestones are known as dependencies. The first task in a dependency relationship is known as a predecessor, which is followed by a successor.

In Workbench, all dependencies must be made between tasks and milestones. The system does not let you create dependencies that include phases or activities.

**Learning Objectives:**

**Lesson 1:** Dependency Concept

**Lesson 2:** Dependency Types and Lag

**Lesson 3:** Creating Dependencies

**Exercises** – Hands on practices
6.1 Dependency Concept

Dependencies are critical in the formation of project schedules. As shown in the diagram below, the Work Breakdown Structure tasks and milestones need to be formed into a logical network that sequences the work – a Dependency Network. This forms the basis of the scheduling that will be performed in Module 8 Project Scheduling.
6.2 Dependency Types and Lag

Dependency Types

There are four types of dependency relationships:

<table>
<thead>
<tr>
<th>Dependency Relationship</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finish-Start</td>
<td>The finish date of the predecessor task determines the earliest possible start date for the successor task.</td>
</tr>
<tr>
<td>Finish-Finish</td>
<td>The finish date of the predecessor task determines the earliest possible finish date for the successor task.</td>
</tr>
<tr>
<td>Start-Start</td>
<td>The start date of the predecessor task determines the earliest possible start date for the successor task.</td>
</tr>
<tr>
<td>Start-Finish</td>
<td>The start date of the predecessor task determines the latest possible finish date for the successor task.</td>
</tr>
</tbody>
</table>

Workbench uses the dependency sequences and the task durations to determine the Critical Path of the project. The Critical Path is the longest path through the network, based purely on dependencies and task durations.

The task and milestone dependencies created in Workbench are not displayed in the Clarity user interface.

Finish-Start
The start date of the successor is scheduled after the finish date of the predecessor. This is the default defined in the Options settings.

| 10 | Task 1 | 11/03/03 | 11/05/03 |
| 20 | Task 2 | 11/07/03 | 11/10/03 |

Finish-Finish
The finish date of the successor is scheduled after the finish date of the predecessor.

| 10 | Task 1 | 11/03/03 | 11/06/03 |
| 20 | Task 2 | 11/05/03 | 11/06/03 |

Start-Start
The start date of the successor is scheduled after the start date of the predecessor.
Start-Finish
The finish date of the successor is scheduled after the start date of the predecessor.

<table>
<thead>
<tr>
<th>Task</th>
<th>Start Date</th>
<th>Finish Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task 1</td>
<td>11/03/03</td>
<td>11/06/03</td>
</tr>
<tr>
<td>Task 2</td>
<td>11/03/03</td>
<td>11/04/03</td>
</tr>
</tbody>
</table>

Dependency Lag

The timing of dependencies may also be governed by an amount of lag. Lag places a predetermined amount of time between the predecessor and successors in the plan. Lag may be expressed as a positive number to indicate a gap between the dependencies or as a negative number to indicate an overlap. Workbench allows you to define lag either as a number of days (most common) or as a percentage (percent complete). Lag must be set as a number (positive or negative) and as a type.

Zero Lag
The default type of dependency relationship is defined in the Options settings as Finish-Start 0 Daily. The zero is the amount of lag between the predecessor and the successor. Lag represents a number of business days. Zero lag means the successor is scheduled the first business day after the predecessor.

<table>
<thead>
<tr>
<th>Task</th>
<th>Start Date</th>
<th>Finish Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task 1</td>
<td>11/03/03</td>
<td>11/06/03</td>
</tr>
<tr>
<td>Task 2</td>
<td>11/07/03</td>
<td>11/10/03</td>
</tr>
</tbody>
</table>

Positive Lag
Positive Lag values greater than zero (such as +2) push the successor out further.

<table>
<thead>
<tr>
<th>Task</th>
<th>Start Date</th>
<th>Finish Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task 1</td>
<td>11/03/03</td>
<td>11/06/03</td>
</tr>
<tr>
<td>Task 2</td>
<td>11/12/03</td>
<td>11/13/03</td>
</tr>
</tbody>
</table>

Minus Lag
A negative value for the Lag (such as –1) overlaps the predecessor and successor by one business day.
To Change the Lag

Follow these steps to change the lag:

1. Access task properties for the task by right-clicking a task name and selecting Dependencies, which opens the Dependencies tab where all existing dependency relationships are visible.

2. Use the scroll bar in the Properties box to scroll to the right until the Lag and Lag Type columns are visible.

3. Define a number for Lag and choose either “Daily” or “Percent” for lag type.

4. Select OK to close the window.

**NOTE:** Lag is also available as a data attribute and can be edited in views.
6.3 Creating Dependencies

Much like creating tasks, dependencies can be created in multiple views. Use the view that is most comfortable for you. Dependencies can be created in the following areas:

1. Spreadsheet view
2. Task properties
3. Gantt view
4. Network diagram

1. Entering Task Dependencies in a Spreadsheet View

From any spreadsheet view, dependency relationships can be created. If the dependency columns are not part of the displaying view, the dependency can still be created, and it will just not be visible until the view is changed or the properties are accessed. Select the Dependency Definition view from under the Planning folder.

Creating a Single Successor between Tasks or Milestones

1. Highlight the row selector for the predecessor task.

|-------------------------------|----------|----------|

2. Move the cursor to the successor task name and right-click. Select Make Successor.

|-------------------------------|----------|----------|

| Planning & Analysis           |       |       |
| Perform high level Scoping    |       | 5/7/2007 |
| Perform preliminary Scoping   |       | 5/7/2007 |
| Create preliminary budgeting  | Make Predecessor | 5/6/2007 |
| Develop high level scoping    | Make Successor | 5/6/2007 |
| Perform high level analysis   | Make Chain | 5/6/2007 |
3. The second task is now a successor of the first task selected.

<table>
<thead>
<tr>
<th>Task</th>
<th>Start Date</th>
<th>End Date</th>
</tr>
</thead>
</table>

Creating Multiple Successors between Tasks or Milestones

1. Use Ctrl+Click to select to rows for each of the successor tasks.
2. Move the cursor to the predecessor task and right-click.
3. Select Make Predecessor and all the highlighted tasks become successors.

Creating Multiple Predecessors for a Task or Milestone

1. Use Ctrl+Click to mark the row selectors for each of the predecessor tasks.
2. Move the cursor to the successor task and right-click.
3. Select Make Successor and all of the highlighted tasks become predecessors.

Creating a Chain of Dependencies

1. Find a series of tasks that need to be linked in a dependency chain.
2. Use Ctrl+Click to mark the row selectors for each of the tasks.

**NOTE:** The order in which you select tasks bears no relation to the order in which tasks appear in the chain. The tasks appear in the WBS order (top to bottom = first to last).
3. When all tasks are marked, right-click and select Make Chain.
NOTE: Tasks do not move to their correct dependency positions, but instead become highlighted to show any dependency violations that exist. When you next run Autoschedule or manually adjust the start and finish dates, the tasks move to their correct dates to respect the dependency rules, as shown.

2. Entering Task Dependencies in the Task Properties Window

Dependencies can also be created using the Task Properties window. Follow these steps to enter a dependency relationship using the Task Properties window:

1. Select the initial task (the first half of the relationship).

2. Right-click on a task name to access its task properties and select Dependencies. Or double-click on the row indicator and select Dependencies. All existing dependency relationships become visible.
3. In the **Project Tasks** list, click the + sign to expand the **Phases and Activities** so you can see the tasks and milestones for this project.

4. Highlight the task you want to be the second half of the relationship.

5. Select one of the following:
   - To make the second task a predecessor of the original, select **Add Predecessor**.
   - To make the second task a successor of the original, select **Add Successor**.

6. When all predecessors and successors for the task or milestone have been selected, select **OK** to close the window.

**NOTE:** Any predecessors or successors listed in a **Task Properties: Dependencies** tab are associated with the task name identified in the **Task Properties** window label.
3. **Entering Task Dependencies in the Gantt View**

Follow these steps to create dependencies in a Gantt Chart view:

1. Open the Gantt Chart view.
2. Adjust the time scale from weekly to daily to enlarge the Gantt bars.
3. Select a predecessor cell, for example, Build A.
4. Hold your left mouse button down until the dependency symbol appears.
5. Drag and drop the dependency symbol on a successor task, for example, Build B.

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>June 2004</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Tue Wed Thu Fri Sat Sun Mon Tue</td>
</tr>
<tr>
<td>10</td>
<td>Design</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Build A</td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>Build B</td>
<td></td>
</tr>
<tr>
<td>40</td>
<td>Build C</td>
<td></td>
</tr>
<tr>
<td>50</td>
<td>Test</td>
<td></td>
</tr>
</tbody>
</table>

4. **Entering Task Dependencies in the CPM Network View**

Follow these steps to create a dependency in the CPM Network view:

1. Open the CPM Network view.
2. Select a predecessor cell, for example, Design.
3. Drag and drop the predecessor cell on a successor cell, for example, Build A.
Editing Task Dependencies

After creating dependencies, you may need to edit them. The **Task Properties** window is the easiest place to make updates and changes. Follow these steps:

1. Right-click a task name and select **Dependencies** to access the **Task Properties** window.

2. The **Dependencies** tab is active and all existing dependency relationships are visible.
3. Make changes, as needed.

4. When all predecessors and successors for the task or milestone have been chosen, select OK to close the window.
Deleting Task Dependencies

You can delete dependencies, as needed. Follow these steps:

1. Right-click a task name and select Dependencies to access the Task Properties window.

2. The Dependencies tab is active and all existing dependency relationships are visible.

3. Select the dependency to be deleted, then select the Delete button. The line item is deleted.

4. Select OK to close the window.

Changing the Dependency Type

By default, Workbench makes all dependency relationships a finish to start type. This means that the first task must finish before the second task can start. Each individual user can set their dependency type default in the Options menu. You can change the type of each dependency at any time, as follows:

1. Right-click a task name and select Dependencies to access the Task Properties window.
2. The **Dependencies** tab is active and all existing dependency relationships are visible.

![Task Properties - Create Tollgate Report](image)

3. One at a time, select the dropdown list for each row in the Type column to change the associated dependency’s type. Each row must be selected individually and a new value assigned.

4. After setting the type for each dependency correctly, select OK to close the window.

**NOTE:** The dependency type is also available as a data attribute and can be edited in views.
Exercises

Exercise 6 – Task Dependencies

1. Open the OWB SPT file you saved in Exercise 5: *OWB Student file 2 - Student Exercise.rmp* (the Project Name of this file is *OWB Student Exercise Project*).

2. Create the following dependencies using any of the methods defined in this module:

<table>
<thead>
<tr>
<th>Predecessor Task(s)</th>
<th>...Has a Successor Task(s) of:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Start</td>
<td>Review the Business Justification</td>
</tr>
<tr>
<td>Review the Business Justification</td>
<td>Define High-Level Business Requirements</td>
</tr>
<tr>
<td>Define High-Level Business Requirements</td>
<td>Initiate Phase Complete</td>
</tr>
<tr>
<td>Initiate Phase Complete</td>
<td>Create Requirements Matrix</td>
</tr>
<tr>
<td>Create Requirements Matrix</td>
<td>Define Function 1</td>
</tr>
<tr>
<td></td>
<td>Define Function 2</td>
</tr>
<tr>
<td></td>
<td>Define Function 3</td>
</tr>
<tr>
<td>Define Function 1</td>
<td>Define Complete</td>
</tr>
<tr>
<td>Define Function 2</td>
<td></td>
</tr>
<tr>
<td>Define Function 3</td>
<td></td>
</tr>
<tr>
<td>Define Complete</td>
<td>Review Function Documentation</td>
</tr>
<tr>
<td>Review Function Documentation</td>
<td>Design Function 1</td>
</tr>
<tr>
<td></td>
<td>Design Function 2</td>
</tr>
<tr>
<td></td>
<td>Design Function 3</td>
</tr>
<tr>
<td>Design Function 1</td>
<td>Design Complete</td>
</tr>
<tr>
<td>Design Function 2</td>
<td></td>
</tr>
<tr>
<td>Design Function 3</td>
<td></td>
</tr>
<tr>
<td>Design Complete</td>
<td>Review Design Documents</td>
</tr>
<tr>
<td>Review Design Documents</td>
<td>Build Function 1</td>
</tr>
<tr>
<td></td>
<td>Build Function 2</td>
</tr>
<tr>
<td></td>
<td>Build Function 3</td>
</tr>
<tr>
<td>Build Function 1</td>
<td>Build Complete</td>
</tr>
<tr>
<td>Build Function 2</td>
<td></td>
</tr>
<tr>
<td>Build Function 3</td>
<td></td>
</tr>
<tr>
<td>Build Complete</td>
<td>Conduct System Test</td>
</tr>
<tr>
<td>Conduct System Test</td>
<td>Conduct User Test</td>
</tr>
<tr>
<td>Conduct User Test</td>
<td>Set Up Production Environment</td>
</tr>
<tr>
<td>Set Up Production Environment</td>
<td>Go Live</td>
</tr>
<tr>
<td>Go Live</td>
<td>Implementation Complete</td>
</tr>
</tbody>
</table>
NOTE: Project management tasks should not be included in the dependency network because they could impact the Critical Path.

3. Select the CPM Network view from the Favorites group. Check the graphical results in the network diagram and ensure that the diagram follows the description in the dependency table. If there are any mistakes, the dependency should be deleted or edited in the Task Properties box and the file should be saved again.

4. Save your changes to the file: OWB Student file 2 - Student Exercise.rmp
Module 7: Assigning Resources to Tasks

As project manager, once you know what work needs to be done, you should have a good idea of the resources required to accomplish your project tasks. A resource can be a person, a role, equipment, material, or an expense. Resources are defined in terms of days, hours, cost, or quantity; and resource information is defined in terms of availability (calendars), category, role, proficiency, and date of hire.

When roles and resources are assigned to a project staff, they can be assigned to individual tasks. The assignment of resources to tasks is the building block for creating estimates on a task. Each resource assigned to a task can be given an *Estimate to Complete* (ETC) for that task. The combined resource ETCs for the task determine the total effort for the task, activity, phase, and project.

**Learning Objectives:**

Lesson 1: Assigning Resources Using Views

Lesson 2: Assigning Resources Using Task Properties

Lesson 3: Releasing Resources from Tasks

**Exercises** – Hands on practices
7.1 Assigning Resources Using Views

Assigning a Resource to a Tasks in a View

1. From the Planning group on the View Shortcut bar, select the Resource Assignment view.

2. From the Resource section of the view, select a resource by selecting its row selector (the gray box on the left of the resource name/id).

3. Once a row is highlighted, move the cursor to the Name cell, hold down the left mouse button, drag the resource straight up, and drop it on the appropriate task name where the resource assignment is being made.

4. The ID for the assigned resource appears in the appropriate column in the view.
5. Move the cursor to the ETC column and enter the amount of work effort required for the resource on this task. The default measurement for ETC is hours.

****CAUTION:**** Do not create new resources in the Workbench project plan and assign them to tasks. Clarity will not allow the project to be saved in the repository. You will lose any work performed.

Assigning Multiple Resources to the Same Task

1. From the Planning group in the View Shortcut bar, select the Resource Assignment view.

2. From the Resource section of the window, select multiple resources by selecting multiple row selectors while holding down the CTRL key.

3. After selecting the resource rows, place the cursor on the Name cell of any of the selected resources, drag the resources straight up to the Task section of the window, and release the resources on the appropriate task.

4. Move the cursor to the ETC column and enter the amount of work effort required each resource on the task. Each resource can have a different ETC.

7.2 Assigning Resources Using Task Properties

Resources can also be assigned to tasks using the Task Properties window.

1. Right-click a task name in any view and select Assignments from the menu. The Task Properties window opens with the Resources tab active.

2. Project resources are listed in a table at the bottom of the window. Assigned resources are tabulated in the top.

3. From the Project Resources list (below), select the row selector for the desired resource, then select Assign.
4. After the selected resource has been added to the Assigned Resources section, move the cursor to the Estimate column and enter the amount of work effort required for the resource on this task.

5. To accept the resource assignment information, select OK.

7.3 Releasing a Resources from a Task

At times it may be necessary to remove a resource from a task. In Workbench, you can do this only by using the Task Properties window. Resources cannot be removed in a spreadsheet view.

1. Right-click the task name and select Assignments from the menu. The Task Properties window opens with the Resources tab active.

2. Project resources are listed in a table at the bottom of the window. Assigned resources are tabulated in the top.

NOTE: To sort the list alphabetically, click the Name column heading.
3. From the Assigned Resources list, select the row selector for the resource to be removed, then select **Release**.

**CAUTION:** You cannot release a resource from a task if the resource has booked Actuals to the task.
Exercises

Exercise 7 – Assigning Resources to Tasks with ETC

1. Open the OWB SPT file you saved in Exercise 6: OWB Student file 2 - Student Exercise.rmp (the Project Name of this file is OWB Student Exercise Project).

2. Modify the Resource Assignment view in the Planning folder as follows:
   a. Replace the Resource ID with the Resource Name.
   g. Add a Column Total to the ETC field (format the data element).
   h. Add the Task Total Usage ETC data element and Column Total
   i. Add the Charge Code data element
   j. Mark the Resource LOA checkbox on the Description tab.

3. Assign Roles and ETCs to the tasks, as indicated in the following table using any of the methods from this module:

<table>
<thead>
<tr>
<th>Task</th>
<th>Role</th>
<th>ETC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Review business justification</td>
<td>CSK Project Manager</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>CSK Business Analyst</td>
<td>8</td>
</tr>
<tr>
<td>Define business requirements</td>
<td>CSK Project Manager</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>CSK Business Analyst</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>CSK Systems Analyst</td>
<td>12</td>
</tr>
<tr>
<td>Create requirements matrix</td>
<td>CSK Business Analyst</td>
<td>34</td>
</tr>
<tr>
<td>Define Function 1</td>
<td>CSK Business Analyst</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td>CSK Systems Analyst</td>
<td>21</td>
</tr>
<tr>
<td>Define Function 2</td>
<td>CSK Business Analyst(2)</td>
<td>14</td>
</tr>
<tr>
<td></td>
<td>CSK Systems Analyst</td>
<td>14</td>
</tr>
<tr>
<td>Define Function 3</td>
<td>CSK Business Analyst</td>
<td>20</td>
</tr>
<tr>
<td>Review function documents</td>
<td>CSK Business Analyst(2)</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>CSK Systems Analyst</td>
<td>18</td>
</tr>
<tr>
<td>Design Function 1</td>
<td>CSK Systems Analyst</td>
<td>35</td>
</tr>
<tr>
<td>Task</td>
<td>Role</td>
<td>ETC</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------</td>
<td>-----</td>
</tr>
<tr>
<td>Design Function 2</td>
<td>CSK Systems Analyst</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>CSK Database Analyst</td>
<td>7</td>
</tr>
<tr>
<td>Design Function 3</td>
<td>CSK Systems Analyst</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>CSK Developer</td>
<td>9</td>
</tr>
<tr>
<td>Review design documents</td>
<td>CSK Developer</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>CSK Developer(2)</td>
<td>12</td>
</tr>
<tr>
<td>Build Function 1</td>
<td>CSK Developer</td>
<td>60</td>
</tr>
<tr>
<td>Build Function 2</td>
<td>CSK Developer(2)</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>CSK Database Analyst</td>
<td>8</td>
</tr>
<tr>
<td>Build Function 3</td>
<td>CSK Developer</td>
<td>35</td>
</tr>
<tr>
<td>Conduct system test</td>
<td>CSK Systems Analyst</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>CSK Developer</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>CSK Developer(2)</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>CSK Database Analyst</td>
<td>14</td>
</tr>
<tr>
<td>Conduct user test</td>
<td>CSK Business Analyst</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>CSK Business Analyst(2)</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>CSK Systems Analyst</td>
<td>24</td>
</tr>
<tr>
<td>Set up production environment</td>
<td>CSK Database Analyst</td>
<td>6</td>
</tr>
<tr>
<td>Go live</td>
<td>CSK Systems Analyst</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>CSK Developer</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>CSK Developer(2)</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>CSK Database Analyst</td>
<td>6</td>
</tr>
<tr>
<td>Project control and administration</td>
<td>CSK Project Manager</td>
<td>80</td>
</tr>
<tr>
<td>Meetings</td>
<td>All team staff</td>
<td>16 each</td>
</tr>
</tbody>
</table>

4. When finished compare the total ETC column to the answer of 876 hours.

5. Save your changes to the file: OWB Student file 2 - Student Exercise.rmp
Module 8: Project Scheduling

Project scheduling in OWB is accomplished using Autoscheduling and is a step in open Workbench that is unique to OWB, but accomplishing the same scheduling events as other schedulers such as Microsoft Project. At its basic state, it simply enforces the task dependencies that have been defined. At its more complex state, which is defined by checkboxes, it help resource level the schedule. Either way, it is completely controllable by the Project Manager and should be a normal routine function in the planning process.

Learning Objectives:

Lesson 1: Factors Affecting Autoschedule

Lesson 2: The Critical Path

Lesson 3: Using Autoschedule

Lesson 4: Using Fixed and Variable Task Duration

Exercises – Hands on practices
8.1 Factors Affecting Autoschedule

Autoschedule is the method in Open Workbench to enforce and initiate several actions. **First** and foremost, Autoschedule enforces the task dependencies that have been defined. Some scheduler application such as MSP enforce dependencies as they are defined, but OWB only does this after Autoscheduling. **Second**, it will calculate the Critical Path, which is important information in any scheduler application. **Third**, it will calculate the task duration if the task is not a ‘fixed duration’. **Fourth**, it will enforce Resource Allocations, but on if the Resource Constraints box is checked. **Fifth**, it will enforce task schedule constraints such as Must Start on. And **Sixth**, it can if checked, schedule the project from the finish date.

8.2 The Critical Path

The Critical Path is the longest path through a project when you view the tasks in the form of a flow diagram defined by the dependencies. Any Critical Path task that slips causes the project to slip by an equal amount of time. Tasks on the Critical Path therefore have no float, that is, the time a task can slip without impacting the Critical Path.

As time gets tracked against tasks on timesheets, some tasks invariably finish early or late. Therefore the Critical Path changes on a weekly basis. The project manager needs to be able to “see” changes to the Critical Path so they can focus resources on the right tasks for a given week, for example, tasks on the Critical path that risk pushing out the project’s completion date.

Autoschedule is the tool the project manager uses to calculate the latest Critical Path. Autoschedule recalculates the Critical Path each time it runs.

Critical Path Method (CPM) Terms and Definitions

**Early Start (ES)**
The earliest date a task can start without affecting other task start or finish dates.

**Early Finish (EF)**
The earliest date a task can finish without affecting other task start or finish dates.

**Late Start (LS)**
The latest date a task can start without affecting other task start or finish dates.

**Late Finish (LF)**
The latest date a task can finish without affecting other task start or finish dates. The latest dates a task can be completed without adversely affecting the Critical Path of a project.
**Float**
The number of days that a task may be delayed or lengthened without adversely affecting the Project Finish Date. This is calculated as LS - ES.

**Subnets**
A subnet is any group of tasks joined by dependencies or a single task with no dependencies. The Subnets option in Workbench allows a project’s critical path to be calculated separately for each subnet (during Autoschedule or when invoking Tools>Critical Path), instead of calculating one critical path for the entire project.

**Understanding the Critical Path**

The following image provides a graphical look at the Critical Path. There are three paths displayed in this view.

1. Design → Build A → Test: Total duration = 8 days
2. Design → Build B → Test: Total Duration = 10 days
3. Design → Build C → Test: Total duration = 9 days

The second path is displayed in red because it has the longest total duration. This is the Critical Path. The other two paths have shorter durations, which means they have float, in these examples, two (Build A) and one (Build C) day. Float allows the tasks on these paths to slip—either one or two days—without risking the project end date.

Note that tasks on the Critical Path are not necessarily the most “important” tasks in the project. Rather they have the longest total duration when combined.

**8.3 Using Autoschedule**

Instead of using manual scheduling, Workbench provides an automatic scheduling function, Autoschedule, which aids the process by attempting to schedule each task for the earliest
possible start date, based on the task’s dependency relationships. Autoschedule does the following:

- Determines the duration of all tasks.
- Calculates the critical path.
- Moves tasks to relieve dependency violations and the over-commitment of resources.

**How Autoschedule Works**

Autoschedule performs the following steps when creating a project schedule. By default, Autoschedule attempts to develop a schedule in which all dependencies are satisfied and resources are not over-allocated.

To create the schedule, Autoschedule performs three distinct traversals through the project data. These run automatically and seamlessly when Autoschedule is initiated.

**Following Autoschedule Rules**

In producing a project schedule, Autoschedule follows a number of internal rules. Tasks are scheduled to minimize the Critical Path (subject to priority), satisfy all dependencies, and use availability as early as possible without over-committing resources.

Autoschedule adheres to the following rules:

- Autoschedule does not reschedule tasks that are:
  - Locked
  - Fixed Locked
  - Completed
- The start date of started tasks is not changed.
- Started tasks are scheduled ahead of non-started tasks.
- The duration of a fixed-duration task is not changed.

The Fixed Duration data element has two settings that apply only to tasks:

1. Unchecked (Variable)

Variable duration tasks are resource constrained. The duration of the task is determined by the ETC assigned to the resource and the
availability of the resource. This is the default setting located in Tools>Options>Defaults.

2. Checked (Fixed)

Fixed duration tasks are time constrained. The duration of the task is created manually or by using Autoschedule.

- The date constraints, Must Start On and Must Finish On, for forward and backward scheduling, respectively, override dependencies.
- Tasks are scheduled at a daily level. For example, resource conflicts are resolved on a day-by-day basis, using remaining availability. These conflicts may not be immediately apparent, for example, by looking at a weekly time scale on the Gantt Chart.
- Cost resources do not constrain the schedule.

Running Autoschedule

After determining that a plan is ready for Autoscheduling, there are a few more decisions to make.

To use Autoschedule to create a basic schedule, follow these steps:

1. Select Tools>Autoschedule from the main menu or click the Autoschedule toolbar icon. The Autoschedule dialog box appears.

2. Populate the following fields, as needed:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Date</td>
<td>Enter the date from which to begin scheduling tasks. If you are using Schedule from Finish Date, enter the finish date. Use the first day after the last timesheet posting for in-progress projects. Use the project start date for projects</td>
</tr>
</tbody>
</table>
### Field | Description
---|---
Ignore Tasks Starting Before | Enter a date if you want to exclude tasks that start before the date.
Ignore Tasks Starting After | Enter a date if you want to exclude tasks that start after the date.
Resource Constraints | If this is not checked, a schedule is created based purely on dependencies, without taking resource constraints into account. If this is checked, resource allocation is considered when scheduling.
Schedule from Finish Date | Use to create a schedule based on a finish date and moving backward, rather than scheduling from a start date forward.

3. Select **OK**. Autoschedule runs immediately.

**NOTE:** *Today’s date is the default date for Autoschedule. If the project imposed start date is larger than this, it overrides the today’s date setting; however, there is no change in the dialog box.*

## Backward/Reverse Autoschedule

If you want to schedule a project from a specified finish date or schedule tasks with priority given to the finish date, use the Schedule from Finish Date option. This finds the latest date the project and tasks can start, while still meeting the desired finish date.

When using this option, Autoschedule does the following:

- Schedules the project from a specified finish date. This date can be:
  - the imposed project finish date
  - calculated from the finish date of the last task
  - a date typed in by the user
- Reschedules tasks using the Late Finish date, going backward in time.
- Enforces finish constraints over start constraints (the reverse of the usual order).

**NOTE:** *If there are actuals on tasks, resources over-allocation may occur when using the Schedule from Finish option, because actuals cannot be moved.*
Scheduling a Project from a Finish Date

4. Select **Tools>Autoschedule** from the main menu, then select the Schedule from Finish Date option.

5. The Start Date is changed to the Finish Date.

6. In the Finish Date field, enter the date you want to schedule from and select **OK**.

**NOTE:** Today’s date is the default date for Autoschedule. If the project imposed start date is larger than this, it overrides the today’s date setting; however, there is no change in the dialog box.

8.4 Using Fixed and Variable Task Durations

In the OWB Task Properties, the distinction between **Fixed Duration** and **Variable Duration** is just a small check in the Fixed Duration check box:
Yet in OWB scheduling, it is an entirely different scheduling experience. Many Project Managers prefer **Fixed Duration** task scheduling because they often know better than OWB what is the best duration for the task. If the Fixed Duration is check, the schedule for each task and for the project is based on the task duration values entered by the project manager. If it is not check and is therefore **Variable Duration**, OWB calculates the task duration based on two different cases: 1) **Resource Constraints** is NOT checked in Autoschedule, in which case OWB calculates the duration of the task simply based on the ETC of the task, and 2) **Resource Constraints** IS checked in Autoschedule, in which case OWB calculates the duration (and the start date) base on some very complex rules.
Exercises

Exercise 8: Using Autoschedule

1. Open the OWB SPT file you saved in Exercise 7: OWB Student file 2 - Student Exercise.rmp (the Project Name of this file is OWB Student Exercise Project).

2. Modify the Gantt Chart view as follows:
   a. F3 to edit the view
   b. Add Fixed Duration? (after name)
   c. Add Duration (and Column Totals) next
   d. Add Column Totals on Start and Finish
   e. Add Resource Name
   f. Add Resource Assignment ETC (and Column Totals)
   g. Add (Task) ETC (and Column Totals)
   h. Add Resource LOA
   i. Name Autoschedule Gantt in Description tab
   j. Save view in the Planning Group
   k. View results
   l. F3 edit view to change the column headings
   m. Rename Column Headers to make more clear and adjust width
   n. Save - Replace

3. Autoschedule your project from today’s date with the Resource Constraints checkbox marked. Also mark the Start Successors on Next Day checkbox. Review the results in the Autoschedule Gantt Chart (change calendar to weeks, if not already there) and view the tasks and dependencies.
4. Check the new **Autoschedule Gantt** view (should show in the Duration Total field – note the thick horizontal line task area and resource area, you may need to drag the line up or down to see the total): What is the current (total) duration of your project? **(53 days)**

5. Autoschedule again with the **Resource Constraints** checkbox unmarked.

6. What is the (total) duration of your project? **(39 days)**

7. Which roles are overcommitted? (Business Analyst, Systems Analyst, Developer, Project Manager).

8. Do your results match those of the instructor? If not, you might want to check the following:
   a. Is the dependency network complete and does it match the instructor’s network?
   b. Are the total project hours correct?
   c. Have you flip-flopped on hours on tasks with multiple resources, where the resource ETCs were different? Review Exercise 7.

9. **Save** your changes to the file: **OWB Student file 2 - Student Exercise. rmp**
Module 9: Refining the Schedule

Having created an initial project schedule in Module 8 – Autoscheduling, Refining allows you to revise that schedule and see what the real schedule limitations are, and whether you can correct them. There are several techniques for refining or optimizing your schedule, which include:

- Fixing duration and locking dates for key tasks, such as meetings, training, and sign-offs.
- Balancing the project workload across existing team members.
- Adding additional available resources to tasks where resources are constrained.
- Making sure the correct loading patterns are used.

Learning Objectives:

Lesson 1: Factors Affecting the Schedule

Lesson 2: Resource Loading Patterns

Lesson 3: Transferring Assignments Between Resources

Exercises – Hands on practices
9.1 Factors Affecting the Schedule

This section discusses the most common factors affecting a project schedule.

1. Fixed Duration Tasks

Autoschedule calculates the optimum duration for a task, based on the availability of any resources assigned and the work effort involved. Autoschedule calculates duration using the following equation:

\[
\text{(resource ETC on a task)} \div \text{(daily resource availability)} = \text{duration (rounded up to the nearest full day)}
\]

For example:

Joe is assigned twenty (24) hours on Task X. His daily availability is eight (8) hours. Task X would have a duration of three (3) days.

Twenty (24) hours of ETC divided by eight (8) hours availability = three (3) day task duration.

This is known as a variable duration type.

However, sometimes the project manager needs to specify the duration of a task. A meeting task, for example, is time constrained rather than resource constrained. An eight-hour meeting does not finish any faster if additional resources are assigned to it. In such a case, the duration type should be fixed.

Fixed duration is also an excellent choice for a task with no resources assigned. For example, you have ordered a server, which is supposed to be delivered in four weeks (twenty work days). You can create a twenty-day fixed duration task, \text{“}Company XYZ to build and deliver server\text{“}. No resources would be assigned, but your project schedule would show the time allocated to delivery of the server by the vendor.

Often, it is more clear for the project manager to make all tasks Fixed duration which will help keep the some of the \text{“}parts\text{“} of the plan from moving unexpectedly, much like they might do in MSP with Fixed duration task type.

To change a task’s duration to fixed, follow these steps:

1. Double-click the row selector for the task to access the Task Properties window.

2. In the Task Properties window, select the Fixed checkbox. If necessary, modify the duration of any task.
3. Select OK.

You can also change the task duration to fixed by marking the Fixed? Column checkbox in the Schedule view.

2. Locking Task Duration and Dates

As project manager, you can prevent Autoschedule from modifying tasks that should stay fixed or locked. For example, you can lock certain dates, such as the start and finish dates for a training class, preventing the dates and the task duration from changing.

You must lock any task that needs to occur on a specific date, preventing Autoschedule from rescheduling it. After being locked, the task cannot move from the specified dates.

To lock a task, follow these steps:

1. Double-click the row selector for the task, which opens the Task Properties window.
2. In the Task Properties window, select the Advanced tab.
3. Scroll down the list of fields and mark the Lock for Scheduling? checkbox.
4. To accept the change, select OK.

You can also lock a task by marking the Locked? Column checkbox in the Schedule view.

Tasks that are locked for scheduling are, by default, shaded in gray in the Gantt Chart.

**CAUTION:** Locking target completion dates for project phases or for the entire project is not recommended. Doing so can eliminate visibility into which tasks are late and which tasks are on the Critical Path. It can result in completely manual, time-consuming management of the project schedule.

3. Changing Task Priority

You can change the priority of a task from the Task Properties window or directly in a view. A task priority can be any number between 0 and 36. The lower the number, the higher the priority given to that task. By default, task priority is inherited from the next highest WBS object.

Priority is invoked if two tasks require the same resources at the same time in the plan. The lower priority task receives preference. If all priorities are equal, preference is given to the first task Autoschedule sees (the highest on the plan). Using Priority is not normally necessary for most project schedules, but if you have a project that is comprised only of a work list of items, it could be appropriate.
Changing the Priority

1. Double-click a task row selector to open the Task Properties window.
2. Clear the Inherited checkbox and enter a priority for the task. 0.

Setting All Tasks with the Same Priority

Use the Inherited priority to make sure all tasks in a project phase or project activity share the same priority. Follow these steps:

1. Click the row selector for the first task within an activity, then hold down the Shift key and click the row selector of the last task.
2. Right-click and choose Modify from the menu.
3. From the Task Properties: Multiple Selections window, select Inherited, then select OK.

4. Setting Task Constraints

Task constraints offer you additional control over how Autoschedule plans your project. These constraints allow for specific dates to drive scheduling. Autoschedule attempts to meet all the constraints you set; however, resource availability and dependency relationships take precedence over task constraints. If multiple constraints are used, the most restrictive constraint is honored by Autoschedule.

**CAUTION:** If a project has a realistic dependency network, using task constraints may be ill advised. Don’t complicate a project unnecessarily!

You can use the following task constraints:

<table>
<thead>
<tr>
<th>Constraint</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Must Start On</td>
<td>This date will always be respected unless the task is locked to other dates. This date defines the date on which the task must start.</td>
</tr>
<tr>
<td>Must Finish On</td>
<td>This date will always be respected unless the task is locked to other dates. This date defines the date on which the task must finish.</td>
</tr>
<tr>
<td>Start No Earlier Than</td>
<td>An attempt is made to schedule the task to start after this date.</td>
</tr>
<tr>
<td>Start No Later Than</td>
<td>An attempt is made to schedule the task to start before this date.</td>
</tr>
<tr>
<td>Finish No Earlier Than</td>
<td>An attempt is made to schedule the task to finish on or after this date.</td>
</tr>
<tr>
<td>Finish No Later Than</td>
<td>An attempt is made to schedule the task to finish on or before this date.</td>
</tr>
</tbody>
</table>
To set up a constraint on a task, follow these steps:

1. Double-click the row selector for the task, which opens the Task Properties window.
2. Select the Advanced tab.
3. Enter the date for one or more constraints listed at the top of the tab, then select OK when finished.

### 9.2 Resource Loading Patterns

Loading patterns determine how the workload of a task is distributed. Although loading patterns can impact a project schedule, their purpose is not to adjust a project schedule. Rather loading patterns are designed to make sure a resource’s workload on a given task is scheduled in accordance with the way work must be done, that is, to keep the schedule realistic.

Workbench provides five loading pattern options, and Autoschedule redistributes work effort across the duration of a task, according to the selected loading patterns:

<table>
<thead>
<tr>
<th>Loading Pattern</th>
<th>Work Effort Distribution</th>
</tr>
</thead>
<tbody>
<tr>
<td>*Front Loading</td>
<td>Work effort is loaded as close to the start of the task as possible.</td>
</tr>
<tr>
<td>*Back Loading</td>
<td>Work effort is loaded as close to the end of the task as possible.</td>
</tr>
<tr>
<td>*Contour Loading</td>
<td>Work effort is loaded as evenly as possible across the duration of the task.</td>
</tr>
<tr>
<td>Uniform Loading</td>
<td>Work effort is loaded as in an exact, even pattern.</td>
</tr>
<tr>
<td>Fixed Loading</td>
<td>Work effort distribution is manually entered by the project manager. Autoschedule ignores fixed loading patterns.</td>
</tr>
</tbody>
</table>

* = variable duration type

### Using Loading Patterns

The five loading pattern options are defined as follows:

1. **Front**
   
The front loading pattern is the default setting in the Tools>Options>Defaults tab. It uses the available hours as early as possible to get the work done as soon as possible.

2. **Back**
   
The back loading pattern can be useful for scheduling hours for a resource that should come in at the end of a task (that is, review code at the end of a develop task).
3. Contour

The contour loading pattern tells Autoschedule to spread the hours as evenly as possible across the duration of a task. **It is often used with a Fixed Duration task to spread the workload.**

4. Uniform

Use the uniform loading pattern when you want Autoschedule to schedule the same amount of hours in each business day of the task. Unlike the contour loading pattern, the uniform loading pattern does not adjust based on availability. It looks into the future for enough days in a row to schedule the hours evenly, skipping over any days or time periods that lack sufficient availability.

**CAUTION:** *This loading pattern is dangerous to use an NOT recommended, because it can move tasks out to unrealistic dates.*

5. Fixed

The fixed loading pattern is useful for scheduling support tasks or meetings with an even distribution of hours in the time periods. It requires you to enter the hours directly into a spreadsheet and the task is ignored by Autoschedule and treated the same as a locked task.

**NOTE:** *An advantage to using this loading pattern is that the hours in future time periods do not increase or reduce as actual hours are posted to the task (i.e. ETC is not decremented). Future ETCs are adjusted by what was worked (or not worked) in the current week!*

### Setting a Loading Pattern

Loading patterns must be set for each task assignment independently. Follow these steps:

1. From the **Executing** folder on the **View Shortcut** bar, select the Schedule view.

2. Click the **Loading Pattern** column of the task you wish to modify, then select the new loading pattern from the dropdown list.

3. Tab out of the field to see the new loading pattern.

4. If you need to set all the tasks with the same loading pattern, use windows copy/paste from this assignment down the column in the Schedule view.
Setting a Fixed Loading Pattern

Rather than letting Autoschedule determine the distribution of work on a task, use the Fixed loading pattern to specify the exact dates and number of hours day by day.

1. From the Executing folder on the View Shortcut bar, select the Schedule view.

2. Edit the view to display days rather than weeks by moving the cursor to the time scale section and double-clicking. Select Daily from the Scale drop-down list and increase the number of time periods to 140.

3. Set the loading pattern for a resource on a task to Fixed.

4. Locate the cell for the actual date the work will be completed and enter the amount of work effort required by each resource on each specific day. Continue to type the specific daily assignment for the task.

**CAUTION:** You may need to run Autoschedule to eliminate any resource over-commitment issues that may have occurred.

9.3 Transferring Assignments Between Resources

In Workbench, project managers can easily transfer all or some work assignments from one resource or role to another resource or role. However, remember these rules when transferring assignments:

- Only current assignments can be transferred.
- Completed assignments do not display.
- Existing actuals are not transferred between resources; only the remaining portion of the assignment is transferred.
- If you transfer an assignment with actuals, the assignment start date for the resource receiving the assignment is the next date after the last actual was entered.
- ETC is also transferred, and the finish date for the assignment does not change.

To transfer assignments, follow these steps:
1. Select **Tools>Transfer Assignments** from the menu bar, which opens the **Transfer Assignments** dialog box.

   ![Transfer Assignments dialog box](image)

2. In the **Transfer assignments from this resource** dropdown list, select the resource from which you want to transfer assignments. The bottom left corner of the window displays all of the resource’s assignments.

3. In the **to this resource** dropdown list, select the resource to which you want to transfer assignments.

4. From the bottom left portion of the window, select the assignments you want to transfer and click the right arrow button to assign them to the new resource.

5. Mark the **Keep Baselines** checkbox, if you want to transfer the baseline.

   **NOTE:** You can also use the **All** button to transfer all displayed assignments to the new resource. The **All** button is enabled if the project has at least one assignment and two resources.
Exercises

Exercise 9: Refining - Adjusting Loading Patterns

1. Open the OWB SPT file you saved in Exercise 8: OWB Student file 2 - Student Exercise.rmp (the Project Name of this file is OWB Student Exercise Project).

2. Open the Resource Assignment view in the Planning folder in Workbench.

3. The current plan is to have the Database Analyst performing Design Function 2 with the System Analyst on the last day of the task. To effect this in the plan, change the Database Analyst’s loading pattern to Back.

4. The Developer is supposed to provide assistance to the System Analyst on Design Function 3 during the full duration of the task. Change the Developer’s loading pattern to Contour.

5. The Database Analyst is supposed to assist Developer (2) on Build Function 2 through the full task duration. Change the Database Analyst’s loading pattern to Contour.

6. The Database Analyst is only to be involved in Conduct System Test about 50% of the total test time through the full task duration. Change the Database Analyst’s loading pattern to Contour.

7. Save your changes to the file: OWB Student file 2 - Student Exercise.rmp

Exercise 10: Refining – Transferring Assignments

1. Open the OWB SPT file you saved in Exercise 9: OWB Student file 2 - Student Exercise.rmp (the Project Name of this file is OWB Student Exercise Project).

2. Are there opportunities to better utilize your staff on the project? Make the following changes:

   a. The System Analyst is the primary resource bottleneck. System Analyst and Developer 2 have similar skill sets. Filter on the System Analyst using Tools>Transfer Assignment from the menu bar, transfer Design Function 2 from System Analyst (transfer assignments from….to this resource). Re-Autoschedule with the Resource Constraints checkbox marked. Duration decreased from 53 days to 48 days.
b. Re-Autoschedule again with **Resource Constraints unchecked**. Developer 1 is now the major resource constraint. Filter on Developer 1. Transfer Build Function 3 from **Developer 1** to **Developer 2**. Re-Autoschedule with the **Resource Constraints** checkbox marked. *Duration decreased from 48 days to 45 days.*

c. Uncheck the **Resource Constraints** checkbox and re-Autoschedule. Business Analyst 1 is also a constraint. Filter on Business Analyst, who, alone, is responsible for the entire Create Business Matrix task. Using the **Resource Assignment** view, Add Business Analyst 2 to the Create Requirements Matrix task and split the hours (17 each). Re-Autoschedule with **Resource Constraints** checked. *Duration has decreased from 45 days to 43 days.*

d. Using the **Schedule** view (in the **Executing** folder), set up the **Project Control and Admin task** and **Meetings** task, so both tasks have a duration of 40 days. Use the uniform loading pattern to spread the hours across the 40 days. Then set the loading pattern to Fixed. Remember you must make these fixed duration tasks in order to change the duration. Re-Autoschedule. *Duration now runs 45 days* (you may also get 44 days).

3. Save your changes to the file: OWB Student file 2 - Student Exercise.rmp
Module 10: Staffing Resources

Proper staffing of resources to the project is vital to the success of the project. If resources are assigned to the project that are already committed on other projects or are over-committed, the likelihood of project success diminishes greatly. Therefore, a resource staffing process that works in conjunction with the resource manager is vital to the outcome of the project.

Learning Objectives:

Lesson 1: Staffing the Project

Exercises – No Exercise for this Module
10.1 Staffing the Project with Resources

Once the project has been scheduled and refined, the role demands are now defined and ready for communication with the Resource Manager to staff the project with named resources to replace the roles on the project. However, there is one final step that should be performed prior to communicating with the Resource Manager. That is that the Allocations should be updated based on the Role ETC’s from the refined project plan.

The next step is to Allocate from Estimates for all Roles by selecting (checkbox) all the team members, then click on the More button in the Project Team portlet and select ‘Allocate from Estimates’. This resets the Allocation requirements to agree with the plan.

Once the Role allocations have be re-set to be consistent with the Refined Schedule, the Project Manager is ready to communicate the staffing requirements with the Resource Manager as shown below in the Project Staffing diagram as item 3.

NOTE: Using the Allocate from Estimates can cause scheduling problems in Open Workbench. The problem is that using this approach gives OWB no flexibility for schedule delays – the availability for the resources ends with the ETC end. So a BETTER, BEST PRACTICE method is to edit the resulting Allocation (using the Properties icon on the Project Team portlet) and make the end of an allocation a week or two longer and if the allocation is less than full time, then round to a higher percentage and keep it flat through the allocation.
In the fourth step, the Resource Manager uses the Resource finder icon or from the Unfilled Requirements portlet in Resource Planning menu.
Base on the proposed resource recommendation from the Resource Manager, the Project Manager can then use the Resource Finder for the Role and select the Recommend Resource and click the Replace button.

As part of this step, the Book Confirmation alert is presented to let you know that you are [soft] booking the resource to the project.
At the end of this step, as a result of the booking actions, the resource has now replaced the role for the Allocation and also on all task assignments in the Open Workbench schedule.

As a final step, as the agreement between the Resource Management and the Project Manager that the resource will be the team member, the Booking Status is changed to Hard Booked by the Resource Manager as shown in Step 6 of the above diagram.
Exercises

There is no student exercise, this activity will be done strictly by Instructor Demo.
Module 11: Baselining

Baseline the project is taking a ‘snapshot’ that can be used as a comparison to measure progress and performance. Most often, the PMO establishes the guidelines and processes that govern baselining. This module covers the baselining methodology within Open Workbench and compares to baselining within Clarity.

Learning Objectives:

Lesson 1: More About Autoschedule and ‘Allocate from Estimates’

Lesson 1: Baselining the Project in OWB

Lesson 2: Reviewing the Baseline in Clarity

Exercises – Hands on practices
11.1 More About Autoscheduling and ‘Allocate from Estimates’

**NOTE:** This is an Important Point

**The Case for NOT using Allocate from Estimates**

In a perfect world, we should be able to use Allocate from Estimates to easily modify the initial Role Allocation (100% from project start to project finish), but it is not a perfect world. The Allocate from Estimates step basically makes the Allocation fit like a glove around the ETC plan demand. And that is good, except when the schedule runs into a problem and the Allocation period needs to be extended. Since there is zero Allocation available beyond the Allocation Finish Date, the task schedule goes to the end of the project, at which point it is no longer define as 0% and starts the task schedule.

So prevent this problem and the resulting excess time for the Project Manager to fix the schedule, **DO NOT USE ALLOCATE FROM ESTIMATE**. Use the next section as the method to define the project allocation need.
Manually Build the Role Allocation Profile

Instead of the tight fitting glove of the Allocate from Estimate, you can easily define the Planned Allocation profile where you can Start the Allocation earlier than the ETC plan, use an Allocation % that is rounded UP from the ETC plan, and have an Allocation Finish Date that is later than the ETC plan.

The ETC plan demand for each Role is defined in the Open Workbench Project (Resource Summary Section of the Gantt Chart) and in the Team > Detail sub-tab. In the previous course, Using Project and Resource Management with Clarity, we configured this portlet to show ETC numbers.

1. Use the PROPERTIES icon in the Detail sub-tab portlet to define the Planned Allocation.

2. In the Staff Member Properties box, the Planned Allocation show the default 100% from project start to project finish. Just build the Planned Allocation you propose by defining each SEGMENT of the Allocation, starting in the row below the default and then click the New Row button to add more segments. You need to define the planned allocation from Project Start to Project Finish, so there may be two or three segments.
3. The Planned Allocation is defined in the Planned Allocation section of the Staff Member Properties and then saved. In the case of the Developer, the Allocation Start was set at few days (beginning of the week) earlier than the ETC plan and was Allocation Finish was several weeks longer than the ETC plan.
4. Each Role Planned Allocation was defined manually with the results as shown in the Team >Detail sub-tab below. Note that you can easily compare the ETC plan to the Allocation plan in this portlet.

```markdown
<table>
<thead>
<tr>
<th>Resource</th>
<th>Project Role</th>
<th>Allocation</th>
<th>Actuals</th>
<th>ETC</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSK Business Analyst</td>
<td>CSK Business Analyst</td>
<td>Actuals</td>
<td>ETC 40</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Allocation</td>
<td>ETC 40</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Total Usage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CSK Developer</td>
<td>CSK Developer</td>
<td>Actuals</td>
<td>ETC 40</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Allocation</td>
<td>ETC 40</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Total Usage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CSK Project Manager</td>
<td>CSK Project Manager</td>
<td>Actuals</td>
<td>ETC 40</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Allocation</td>
<td>ETC 40</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Total Usage</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

With this approach, you can properly control the communication with the Resource Manager using the Clarity Portlets and have total control of defining the Allocation need, and not have the Autoscheduling issues.


11.2 Baselining the Project in OWB

Setting a Baseline in OWB

The Set Baseline selection acts on the “current baseline.” If there is no current baseline, one is created.

To create a baseline in Open Workbench, follow these steps:

1. From the main menu, select Tools>Baseline>Set Baseline, which opens the Baseline dialog box.

2. Select one of the following:

   - **Project** - The entire project is baselined.
   - **View** - Only those tasks visible in the currently-applied view are baselined.
   - **Selected Tasks** - Only available if WBS items have been selected in the view

3. Select Set under Baseline Settings.

   **NOTE:** Select Clear to clear a project's baseline.

4. Select OK.

The Gantt Chart now displays both baseline and current schedule (the baseline shows triangles, but can be configured into a Gantt bar). Any changes to the project will affect only the current data; the baseline continues to show the original dates and usage.
The resulting Baseline revision code and name can be viewed in the Multiple Baseline selection, which can be edited to better define the baseline.

Working with Multiple Baselines

The Multiple Baselines functionality allows you to create new additional baselines as well as see a list of all existing baselines. The Multiple Baselines dialog box displays in tabular format each baseline’s (ID) Code, Name, and Description field. The dialog box includes New and Delete buttons.
There is also a Current checkbox, which, when selected, indicates which baseline in the list is the current baseline. There can be only one current baseline at a time. The current baseline is:

- the one whose values are shown in views and in the property pages
- the one used for analysis
- the one viewable in Gantt charts

Creating Multiple Baselines

To create multiple baselines, follow these steps:

1. Select Tools>Baselines>Multiple Baselines from the menu bar, which opens the Multiple Baselines dialog box where all existing baselines are visible.

2. To create a new baseline, select New. The Code and Name fields auto-populate and can be modified. The Description field defaults to blank and can be filled in or modified by a user with baseline creation rights. The new baseline represents a snapshot for the entire project at the moment you selected New.

3. Mark the Current checkbox if you want the associated baseline to serve as the current baseline.

The following rules are enforced when creating baselines:

- If a project is locked, it cannot be baselined. A project is automatically locked when it is open in Open Workbench or Microsoft Project. To unlock a project, close it in Open Workbench or Microsoft Project.

- Use Open Workbench or Microsoft Project to perform detailed baselining. With Open Workbench, you can baseline the entire project, all of the tasks in a view, or selected tasks. See Using Clarity with Open Workbench and Microsoft Project for more information.
11.3 Reviewing the Baseline in Clarity

The project baseline created in Open Workbench can also be view in Clarity in the Properties > Baseline sub-tab. The baseline can be created in either tool and used and viewed in either tool. It is the same baseline. Creating a baseline in Clarity has the advantage of the Auto-numbering, while creating baselines in Open Workbench has the advantages of baseline just certain information in views or selections.
Exercises

**Exercise 11: Baselining the Schedule from OWB**

1. You will now use the new OWB Student File 3 Baseline Exercise.rmp for this excise. This is the same project file with the Roles replaced with Resource. You will not use the previous file again.

2. Open the file OWB Student File 3 Baseline Exercise.rmp

3. To get this file on the same basis as other file, Autoschedule the new file using the same Autoschedule Start Date as the previous files.

4. Open the **Variance Analysis** view in the **Controlling** group.

5. To Baseline the schedule: select **Tools>Baseline>Set Baseline** from the menu bar.

6. **Baseline** your project (Scope = Project and Baseline Settings = Set)

7. **Note** that in the Variance Analysis view the Baseline values populated and the variances are all at Zero (as expected).

8. **Autoschedule** your project out five working days from the current date (in the Start Date field of Autoschedule).

9. **Now note** the schedule (date) variance (should be -5)

10. From the **Tools** menu, select **Baseline>Multiple Baselines**. Create a new baseline (the ID and Name are set automatically, but can be changed by the PM).

11. **Now note** that the schedule variance is now gone, it is zero.

12. **Save** your changes to the file: OWB Student File 3 Baseline Exercise.rmp
Module 12: Monitoring and Control

In the Clarity context, once a project is created and baselined, it is important that project manager monitor and control the project. The statusing and plan updating activities need to be timed around the weekly cycle of timesheet reporting by the project team members. Based on the timesheets, tasks can be started by Clarity based on actual time reported against the task, the ETC for the task (by resource) will be decremented by the amount of actual time against the task for the week.

Learning Objectives:

Lesson 1: Monitoring and Controlling Projects

Lesson 2: The Weekly Review Process

Exercises – Hands on practices
12.1 Monitoring and Controlling Projects

The Weekly Update Cycle is anchored by the weekly Timesheet Posting and governs when the Project Manager should update the project plan. The picture below depicts the weekly update cycle with the explanations below.

**WEEKLY UPDATE CYCLE**

- **CREATE** (Monday) Project Team
  - **POST** Monday Automated Job
  - **RE-PLAN** (Weekly After Posting) Project Mgr.
- **TRACK** (Daily) Project Team
- **SUBMIT** (End of Week) Project Team
- **APPROVE** (Before post) Resource Mgr.
- **REVIEW** (Before Post) Project Mgr.

**Create** – the weekly cycle begins with team members Populating their timesheet for the week. By Populating, it brings into the timesheets only tasks that are currently underway or scheduled to start in the next week.

**Track** – the cycle continues with the daily tracking of task time by the team members. If working a number of tasks, it is generally a better practice to track time daily so that accurate records can be maintained.
Submit – at the end of the weekly timesheet cycle, usually on Friday, each team member ‘Submits’ the timesheet for approval. At that point, it is in the Approvers queue to approve.

Review – because team members often work on a number of projects, it is often difficult to make the PM the timesheet approver. However, there is actually a better way: the PM can review all the timesheets within the project schedule showing team member hours by tasks. This review is with the ‘Pending Actuals’ views.

Approve – the manager reviews the timesheets and approves. Timesheets must be approved before they can be Posted.

Post – the timesheets are Posted, which is a business process that moves the actual project assignment hours into Clarity Actual fields, starts tasks (changes status to Started), decrements that resource ETC on each task, and readies the information for further financial posting.

Re-plan – once the weekly posting is complete, the PM can review the schedule, update according to all changed information, and provide status reporting as required. The timing of this activity is important because it cannot start until after posting, yet the revised information may affect team members timesheets.

12.2 The Weekly Project Review

Conducting a weekly review of your project is essential to the project’s health. When the tracking cycle has been completed and all information in the plan is up to date, the project manager should determine whether or not the project is still on target. “On target” can mean different things, for example, meeting the original end date or operating within budget.

As project manager, you should review your project weekly against the following criteria:

- Pending Actuals prior to posting
- Pending Estimates, when staff members have proposed a new ETC
Using Open Workbench with Clarity

- Tasks where the total ETC is zero. Determine why the task is not complete; should additional hours be assigned; should the finish date be moved; or should more resources be added.

- Unplanned tasks and assignments, for example, tasks added using Timesheets. Should they be there? Where should they be placed in the WBS?

- Late Finishing tasks. Are they on the Critical Path? Why are they late?

- Tasks scheduled to start this week. How much float do these tasks have?

- Resource over-commitments and dependency violations that need to be fixed.

- Project variances:
  - Duration variance
  - Start and finish variance
  - Usage (labor) variance

Using Custom Views for the Weekly Review

Building a series of custom views can help streamline the weekly review. The basic premise for using custom views is to filter project data so problems in the plan are easier to spot and isolate. In large project plans, a project manager can suffer data overload having to look through unfiltered information in views displaying too many columns. Getting in the habit of using one view for everything you do with regard to your project plan is a terrible technique for using Workbench. The following custom views limit the data displayed and focus your attention on what has changed and what must be controlled.

(1) Reviewing Pending Actuals

Pending Actuals are created as soon as a team member enters hours on their timesheet and saves the timesheet. Pending Actuals allow the project manager to see on what their team is working before the end of a time tracking cycle and without having access each team member’s timesheet.

At a minimum, you should look at Pending Actuals prior to posting time each week to make sure charges are against the correct tasks and no errors exist that will impact the project plan.

Monitor Pending Actuals using the following custom view:
(2) Reviewing Actuals

After posting is completed, you can review Actuals that have been booked during the previous period by following these steps using an existing view:

1. Open the Status Update view from the Controlling group in the View Shortcut bar.

2. Double-click in the time scale section.

3. Make sure the First Date Displayed field is set to the project start date. That way, you can see all the Actuals tracked so far. Alternatively, you could choose to set the time scale options to show only the previous week’s values.

4. Look for Actuals data in the weekly breakdown section and the Total Actuals section.

(3) Reviewing Pending Estimates

When staff members enter actual hours in their timesheet, they can also enter a new estimate to complete for a task, if they believe the work requires greater or fewer hours to complete than currently stated. These estimates are carried over into a project plan as Pending Estimates. A project manager can review them and decide whether or not to accept them.

Pending Estimates do not automatically update a project plan. Changes are not visible until the project manager accepts them.
To view Pending Estimates, follow these steps using an existing view:

1. Open the **Status Update** view.

2. To see which resources have modified their remaining work, click on the Pending ETC filter in the **Filters & Sorts** group of the **View Shortcut** bar. The page displays only those tasks whose estimate has been revised.

3. After analyzing the pending ETC, select **Tools>Pending Estimates** from the main menu to open the **Pending Estimates** dialog box.

4. You can choose to accept or reject some or all of the newly submitted ETCs. First, select the scope of your determination by choosing one of the following radio buttons:
   - **Project** - Affects all pending estimated hours in the project
   - **View** - Affects all pending estimated hours currently displayed in the view. This option assumes you have already filtered the view.
   - **Selected Task(s)** - Affects only the ETCs for tasks already selected in the view by row

5. Decide whether to accept or reject the specified revisions by selecting **Accept Pending Estimates** or **Reject Pending Estimates**.

6. Select **OK**.

A project manager does not have to accept the full ETC proposed by a resource. You can type a “compromise” value straight into the ETC column. However, in order for the resource to see the new value, you must first reject the pending ETC, then type the new value into the cell.

**CAUTION:** As project manager, if you do not agree with a proposed revised estimate, you must reject it. If you do not, the discrepant ETC will appear on the resource’s next timesheet, giving the impression that the ETC is acceptable.
Review Pending Estimates using the following custom views:

(4) Updating Task Status
When Actuals have accumulated against the project and the revised estimates have been submitted, the project manager must review all tasks and make sure the status for each task is correct. The system automatically changes a task’s status to Started once Actuals have been posted against it. However, the system does not change a task’s status to Completed when the ETC reaches zero automatically; a project manager must do this as part of the review process.

When a project manager changes the task status to Completed, the system changes the task’s % Complete field to 100%. The reverse is not true; marking a task as 100% complete does not change the status to Completed.

To update task status, follow these steps:

1. From the Controlling group on the View Shortcut bar, select the Status Update view.

2. To mark a task or milestone as complete, move the cursor to the Status column and select Completed from the dropdown list.

**NOTE:** You cannot set a task to Completed if any resource shows an ETC other than zero. Zero out each ETC before setting the task status to Completed.
(5) Updating Milestone Status
Because milestones have no work associated with them, often they can be overlooked. However, milestones also should be marked as Completed as soon as appropriate.

Track the status of milestones using the following custom views:

Milestone Status?: Data Elements

Milestone Status?: Filters

(6) Handling Tasks with No ETC
Sometimes the estimate to complete for a task is incorrect and the hours allocated to the task run out before the task is complete. A project manager must identify tasks with no ETC to determine whether to mark the task as Completed or whether to modify the ETC and add hours for resources assigned to the task.

Use the following custom views to help identify tasks with no ETC:
(7) Identifying Late Finishing Tasks

Late Finishing tasks are a critical concern to the project manage, who, as part of the weekly review, should be asking these questions

- Which tasks have a late finish?
- Which of the late tasks are on the Critical Path?
- Why are they late?

Knowing this information helps you focus team resources on any “hot spots” that are delaying the project. Identify Late Finishing tasks using the following custom views:
A project manager needs to identify which tasks are scheduled to start during the upcoming week. As part of the weekly review, you should be asking the following questions:

- Which tasks scheduled to start this week are on the Critical Path?
- How much float is associated with each task?

Having this information allows you to focus the project team’s work effort on tasks that will impact the project schedule. Use the following custom views to help quickly identify these tasks:
Using Open Workbench with Clarity

Scheduled to Start Tasks: Data Elements

View Definition - Scheduled to Start

Scheduled to Start Tasks: Filters

(9) Autoscheduling After Posting

The project manager must Autoschedule the project plan after posting, because scheduling revisions may have been set but will not be fully visible or their overall impacts known. For example:

- Resource over-commitment could result from revised being carried forward to the current period.

- Certain tasks may have had hours added through revised ETCs.

- Other tasks may have had hours deleted through revised ETCs and may have been marked as Completed.

Autoschedule provides the project manager with an instance update for a project by:

- Automatically resolving resource over-commitment, as well as any dependency violations, when possible.

- Rescheduling a new date for any tasks scheduled to start prior to today’s date that have not started.
Using Open Workbench with Clarity

- Not rescheduling completed tasks.
- Not rescheduling the start date of started tasks.

When running Autoschedule, always use the first date of the current tracking period as the start date. For example, if the time reporting period runs Monday – Sunday and Actuals have been tracked and posted through Sunday, the start date should be the next Monday. This ensures that tasks not completed during the previous week are moved into the current week and not left in the previous week and lost.

(10) Reviewing Variances

After work begins on a project and Actuals are booked, everything may not go according to plan. Using the baseline functionality allows the project manager to view the current plan against any plan you baselined and do variance analysis to see where the troubles lie. You can review and analyze the plan on a daily basis as a first defense against undesirable problems. If, after analysis, a project appears on track to miss its deadline, you must consider available options for getting the project back to schedule.

You can study project variance from the Variance Analysis view, which you access from the Controlling group on the View Shortcut bar.

Field names available in Workbench include:

- Start Variance
- Finish Variance
- Duration Variance
- Task Usage Variance
- Resource Assignment Usage Variance

You can use or create different views to produce additional usage and duration variance reports. These views can be at the task or resource level of detail and can help explain areas of project risk. You can save any views you design and use them throughout the project lifecycle.

(11) Opening and Closing Tasks for Time Entry

As a last step in the plan updating process, review the phases/tasks that are Open for Time Entry and decide if any should be Unchecked or Checked (Closed or Opened) for time entry. Closing tasks for completed work is a Best Practice so that time is not inadvertently charged against it. Also, future work that is not planned to start for some time should have the tasks closed for time entry to prevent inadvertent time charges.
Exercises

Exercise 12: Controlling the Schedule

**NOTE:** This exercise is based on a new OWB student file, *OWB Student File 4 – Controlling.rmp*. This project occurs in the past and has Actual time and Pending Time as well as Pending ETCs. Because it is in the past, the exercise instructions include Autoschedule Start dates that are far in the past, but must be used to follow at the end of the timesheet posting period. This will still demonstrate all the required techniques of Controlling the schedule.

**Reviewing a Project Plan**

Open the new OWB student file, *OWB Student File 4 – Controlling.rmp*, which is used for the remainder of Exercise 12.

This project started on 8/13/07. Look at information for the week of 8/20/07 and use this date for Autoschedule.

1. Review pending actuals.
   - Open the Status Update view in the Controlling folder. Add the Pending Actuals data element.
   - Who has pending actuals on the Create Business Matrix task? (Jane Doe, 12 and Don Smith, 16)

2. Review pending estimates.
   - Add the Pending Estimate Override data element to the Status Update view in the Controlling folder. (note, for the exercise, because this is a RMP file, it may have lost its Override Flag, and the results will not display properly)
   - Which tasks have pending estimates?
   - Reject all the pending estimates (for Smith, Forus. and Doe).
   - **NOTE:** Because this is a RMP file, it may lose the Pending Estimate Override flag and not indicate any Pending Estimates. No matter, reject all anyway.
   - Mark any completed milestones as Completed. The **Project Start milestone** should be marked Completed. The start date should be set to 8/13/07 (the day the first actuals were charged to the project).

4. Review the project for tasks with zero ETC.
   Build a custom view for tasks with zero ETC and save the view to the **Controlling folder**.
   - Which task has no ETCs? Is the task completed? Does the task need more ETC?
   - Task **Review the Business Justification** has 0 ETC and should be statused as **Completed**

5. Review the project for late finishing tasks?
   Which tasks have a late finishing date? Build a custom view, as described in the **Weekly Project Review**.

6. Review the project for tasks scheduled to begin this week.
   Which tasks are scheduled to start the week of 8/20/07 to 8/26/07?
   Build a custom view, as described in the **Weekly Project Review** to assist you in identifying these tasks.

7. Autoschedule from **8/20/07**.
   Run Autoschedule with the **Resource Constraints** checkbox marked.

8. Review for any project variances.
   Use the Variance Analysis view in the **Controlling** folder. Add a column total to the **Task Usage Variance** data element to get an overall view of project variances.

9. Review any resource over-commitments.
   Open the Revise Schedule view in the **Controlling** folder.
   - Was anyone overcommitted last week? Why?
10. Review Open /Closed Tasks for Time Entry.

   Add the Open for Time Entry data element (under Task Information, All) to the Gantt Chart.

   Close all tasks in the Design, Develop, and Implement phases. Also close for time entry the completed task **Review the Business Justification**
THANK YOU

For Attending this Course